This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 480509 - MediaWiki fails setup
MediaWiki fails setup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 18:01 EST by eric@christensenplace.us
Modified: 2009-07-31 13:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 23:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the text from the setup including the error. (6.70 KB, text/plain)
2009-01-17 18:01 EST, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2009-01-17 18:01:14 EST
Created attachment 329292 [details]
This is the text from the setup including the error.

Description of problem: When I attempt to setup MediaWiki on a fresh install of Apache and MediaWiki I get the following error:

      Creating LocalSettings.php...

      Warning: fopen(/var/www/wiki/config/LocalSettings.php) [function.fopen]: failed to open stream: Permission denied in /var/www/wiki/config/index.php on line 1115

Couldn't write out LocalSettings.php. Check that the directory permissions are correct and that there isn't already a file of that name here...


Version-Release number of selected component (if applicable): mediawiki-1.13.3-42.fc10.x86_64



How reproducible: Always


Steps to Reproduce:
1. Complete the setup page.
2. Select the "Install MediaWiki" button at the bottom
3. See Failure
  
Actual results: Get permission error

Expected results: All works

Additional info: I tried to copy and paste the information below the error into the LocalSettings.php but the wiki either comes up blank (nothing on the page) or it tells me that I have to do the setup again.
Comment 1 Austin 2009-03-26 03:32:14 EDT
I believe this *might* be an SE Linux problem.

As root, try:
# getenforce

Does it return "Enforcing", or "Permissive"? If the former (Enforcing), try running this as root:
# setenforce Permissive

Then, re-visit the config URL and try again. This worked for me, and if this is your problem, the designer needs to include an SELinux config with the package.

Let me know how you go.

Note You need to log in before you can comment on or make changes to this bug.