Bug 480532 - uname -a showing wrong timezone
uname -a showing wrong timezone
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 08:22 EST by Imtiaz Rahi
Modified: 2009-02-02 07:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 04:34:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Imtiaz Rahi 2009-01-18 08:22:06 EST
Description of problem:
`uname -a` shows EST as timezone whereas BDT is the timezone in my server

Version-Release number of selected component (if applicable):
6.12-18.fc10

How reproducible:


Steps to Reproduce:
1. run date command
2. run `uname -a` command
3.
  
Actual results:
Output from machine
[root@<server> ~]# date
Sun Jan 18 19:21:10 BDT 2009
[root@<server> ~]# uname -a
Linux chitra 2.6.27.9-159.fc10.i686.PAE #1 SMP Tue Dec 16 14:59:37 EST 2008 i686 i686 i386 GNU/Linux

Expected results:
BDT is expected in the output of uname

Additional info:
Comment 1 Kamil Dudka 2009-01-18 10:56:29 EST
What does following command say?
cat /proc/sys/kernel/version
Comment 2 Ondrej Vasik 2009-01-19 04:51:01 EST
Thanks for report, however - that's not a bug. Coreutils's uname(1) utility just calls uname(2) - which returns time of compiling kernel (as part of version string) - with locales at the time of compiling kernel - that's EST - as this is timezone used in koji build system. Similar bug was reported in gentoo (http://bugs.gentoo.org/7799) , closed invalid there. In Fedora NOTABUG.
Comment 3 Imtiaz Rahi 2009-01-19 14:27:37 EST
In debian or ubuntu the output shows UTC which makes much more sense. And its always easy to calculate my time from GMT or UTC. Rather than the EST. The world does not stand on EST. People live everywhere and they calculate their time from UTC and understands that quickly and easily.

Suggesting to show UTC time in uname output.
Comment 4 Ondrej Vasik 2009-01-20 04:34:26 EST
Thanks for suggestion, but I can't do that in uname - it just shows/interprets reports coming from syscall uname(2). Version string is generated at the build time. As koji build system - where are packages build - uses EST time zone, timestamp in kernel version string is generated with EST time zone. I can't change this in coreutils - as version string contains not only date. If Debian/Ububtu uses UTC, their kernel package was compiled on machine with localzone using UTC. Although I agree that usage of "something more general" than EST is good thing, it would probably mean some effort with almost no benefit for Fedora users. I can't change that in coreutils - therefore NOTABUG for coreutils. Koji webpages use UTC, but it seems that buildsystems use EST. It could be discussed in fedora-devel list or reported against koji build system, but there is nothing wrong with uname -a as kernel version is displayed properly, so closing that bug again. Maybe bug against koji (or ticket for fedora rel-eng) with Summary "RFE: Buildsystems should use UTC as their timezone" - with explanation that EST timezone causes kernel version string to be fixed on EST time and making reading of timestamp more difficult to non-US users.
Comment 5 Dennis Gilmore 2009-02-01 12:44:09 EST
fedoras builders all run UTC.
Comment 6 Ondrej Vasik 2009-02-02 03:24:09 EST
Then I can't figure out why kernel string contains EST timestamp in version...
Comment 7 Kamil Dudka 2009-02-02 07:27:40 EST
date command on x86-5.fedora.phx.redhat.com returns EST (tested now: "Mon Feb  2 07:17:22 EST 2009"). This command is used to create kernel version string during kernel build.

Note You need to log in before you can comment on or make changes to this bug.