Bug 480551 - Annoying popup in geeqie when sorting images
Annoying popup in geeqie when sorting images
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: geeqie (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 15:58 EST by Christopher Beland
Modified: 2009-01-26 03:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 03:37:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2009-01-18 15:58:50 EST
I sometimes used gqview to sort photos into subdirectories by dragging and dropping.  This is annoying in geeqie because after each move, there is a pop-up box entitled "Output of External Move command".  There should not be any pop-up unless the move failed or there is some sort of warning or question the user should be alerted to.
Comment 1 Christopher Beland 2009-01-18 16:03:44 EST
I forgot to mention the version number:

geeqie-1.0-0.11.alpha2.1307svn.fc11.x86_64
Comment 2 Michael Schwendt 2009-01-18 17:03:10 EST
Disable verbose output for the External Editors commands in the preferences.
Comment 3 Christopher Beland 2009-01-19 03:59:22 EST
I'm afraid I don't see any setting on any of the tabs in Edit->Preference to change the verbosity of external commands.

I'm also not sure why anyone who is not debugging or developing (i.e. normal users) would want to get a pop-up when there is no error condition.  The application appears to have a debug level setting in the GUI.  Shouldn't verbosity be minimal at the default debugging level?
Comment 4 Michael Schwendt 2009-01-22 03:37:29 EST
Click the "Help" button.

Please don't reopen this ticket. Geeqie is still alpha-level software, which is seeing lots of changes compared with GQview. It is offered in Fedora for evaluation purposes only. If you want application defaults to be changed, submit a request upstream.
Comment 5 Christopher Beland 2009-01-26 03:38:48 EST
I read the documentation, and changing "%vset -x;mv %p %d" to "set -x;mv %p %d" (removing the %v) for "External Move command" fixed this behavior.  Obviously, this is something which is completely beyond the everyday user, especially given it's not clear that there even *is* an option to change this as part of the preference system.

I'm not sure what you mean by "evaluation purposes only"; I thought the point of evaluating alpha software was to find problems and report them.  Since this is a clear usability bug, I will file a request upstream.

Note You need to log in before you can comment on or make changes to this bug.