Bug 480556 - NM updates no longer uses wired connection, eats default route for VPN.
NM updates no longer uses wired connection, eats default route for VPN.
Status: CLOSED DUPLICATE of bug 479317
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 17:35 EST by David Woodhouse
Modified: 2009-01-19 14:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 14:02:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-01-18 17:35:21 EST
I plugged my laptop into a wired connection last night; it failed to connect. 

nm-applet shows 'device is unmanaged', even after I try to use the connection editor to remove 'Auto eth0' and add another wired connection.

Also, when I connect to my VPN, it's started taking my default route, although it's not supposed to be. This only happened in the last few days, since the F-10 NetworkManager update. Attaching the routing configuration for my VPN, from gconf.
Comment 1 David Woodhouse 2009-01-19 14:02:31 EST
First problem is probably 100% user error -- I must have set ifcfg-eth0 to tell NM to ignore that device, some time in the past.

Second problem looks like a duplicate of bug #479317, and is solved by setting the "don't set default route" option in the routing configuration for the VPN.

*** This bug has been marked as a duplicate of bug 479317 ***

Note You need to log in before you can comment on or make changes to this bug.