Bug 480558 - Please remove dependency for wireless-tools from rhpl
Please remove dependency for wireless-tools from rhpl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: FutureFeature
: 503979 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 18:14 EST by Dan Davis
Modified: 2009-10-13 09:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 09:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Davis 2009-01-18 18:14:03 EST
Description of problem:
I have a system with no wireless hardware, yet I must have wireless tools installed to have most of the graphical system configuration tools installed.
Obviously this isn't urgent, it's only 200k of system resources, but it would be nice for those of us without wireless hardware to not need wireless software installed.

Version-Release number of selected component (if applicable):
0.218-1

How reproducible:
Always

Steps to Reproduce:
1. Remove wireless-tools package via yum
  
Actual results:
Processing Dependency: libiw.so.29()(64bit) for package: rhpl
Processing Dependency: rhpl for package: system-config-language
Processing Dependency: rhpl >= 0.6 for package: system-config-boot
Processing Dependency: rhpl for package: system-config-date
Processing Dependency: rhpl >= 0.148.2 for package: system-config-lvm
Processing Dependency: rhpl for package: firstboot
Processing Dependency: rhpl for package: system-config-firewall-tui
Processing Dependency: rhpl for package: system-config-users
Processing Dependency: rhpl >= 0.53 for package: system-config-keyboard
Processing Dependency: rhpl >= 0.193 for package: system-config-network-tui
Processing Dependency: rhpl for package: system-config-rootpassword
Processing Dependency: system-config-network-tui = 1.5.95-1.fc10 for package: system-config-network
Processing Dependency: system-config-firewall-tui = 1.2.13-2.fc10 for package: system-config-firewall

Expected results:
wireless tools should be uninstalled without taking away seemingly unrelated system configuration tools.

Additional info:
Comment 1 Jeremy Katz 2009-01-19 10:49:07 EST
Harald -- can we move the network bits out of rhpl and into system-config-network?  The only thing that uses them is system-config-network and it would be another step towards being able to remove rhpl completely.
Comment 2 Fedora Admin XMLRPC Client 2009-04-14 15:22:10 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Chris Lumens 2009-06-03 13:10:52 EDT
*** Bug 503979 has been marked as a duplicate of this bug. ***
Comment 4 TK009 2009-06-21 11:38:08 EDT
Based on the information in this report I am assigning it, and removing the need info flag.


TK009
Fedora Bug Triage Team.

Note You need to log in before you can comment on or make changes to this bug.