This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 480578 - move the classic network configuration scripts out of the initscripts package
move the classic network configuration scripts out of the initscripts package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraServerTracker
  Show dependency treegraph
 
Reported: 2009-01-19 04:04 EST by Dan Horák
Modified: 2014-03-16 23:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 14:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2009-01-19 04:04:22 EST
With the recent development that makes NetworkManager the default mechanism for network configuration I would like to move the classic network configuration scripts out of the initscripts package into a separate package with me as the submitter/owner of the new package.

affected files:
/etc/rc.d/init.d/network
/etc/sysconfig/network-scripts/*
related part of sysconfig.txt
Comment 1 Bill Nottingham 2009-01-19 14:21:50 EST
To the best of my (occasionally fuzzy) recollection:

- you've never submitted patches for the scripts
- you've never filed bugs against them
- you've never applied even for access to upstream git
  (of course, the first two would be a prerequisite for that)

Ergo, no.
Comment 2 Bill Nottingham 2009-01-19 14:22:30 EST
Without a usage case as to what this would accomplish/serve, I'm not seeing a big reason why this would need to be done.
Comment 3 Dan Horák 2009-01-19 17:30:51 EST
Well, I have got the impression during the previous few months that this feature will be depreciated in the really near future because we have NM. So I am glad to see you are still ready to maintain the scripts as a part of initscripts. But please let me know, when you would like to drop them out.
Comment 4 Dan Horák 2009-01-20 02:59:05 EST
(In reply to comment #1)
> To the best of my (occasionally fuzzy) recollection:
> 
> - you've never submitted patches for the scripts
> - you've never filed bugs against them
> - you've never applied even for access to upstream git
>   (of course, the first two would be a prerequisite for that)
> 
> Ergo, no.

Are those really required for an overtake of a to-be-abandoned feature? I don't think so.
Comment 5 Bill Nottingham 2009-01-20 13:06:53 EST
It's a maintained subsystem, so... yes.

What sorts of changes do you want to make?
Comment 6 Dan Horák 2009-01-20 15:44:13 EST
No changes are planned, it works well AFAIK. I (and the server and other people) just want to make sure it survives, because its role is non-replaceable due the number of variants it allows to configure and no resource usage.

But the split would show a distinction between classic and NM network setups.

Note You need to log in before you can comment on or make changes to this bug.