Bug 480580 - If dmidecode package is installed on an ia64 server, INFO test fails
If dmidecode package is installed on an ia64 server, INFO test fails
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 04:45 EST by Vivian Bian
Modified: 2014-03-25 20:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 10:14:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the output log for the info test (28.80 KB, text/x-log)
2009-01-19 04:45 EST, Vivian Bian
no flags Details

  None (edit)
Description Vivian Bian 2009-01-19 04:45:20 EST
Created attachment 329319 [details]
the output log for the info test

Description of problem: I inadvertently had the dmidecode package installed on a
domU -- and it was causing the info test to run "dmidecode", and that caused the
test to fail because I got the following errors from dmidecode (expected on an
ia64 box):


Wrong DMI structures length: 1257 bytes announced, structures occupy 1259 bytes.
...finished running ./info.py, exit code=1

Version-Release number of selected component (if applicable):
hts-5.3-11

How reproducible: 100%

Steps to reproduce:
[prerequisite]
Make sure the info test suite is enabled
[Steps]
1.Enable the test plan for a hardware for example:
# hts plan -t storage -e
2.Then run the test suite 
# hts run -t storage
3.After the test suite for the storage finished ,the info test suite will be on,and then you will see the fail infomation

Additional info:
Comment 1 Greg Nichols 2009-01-19 10:14:20 EST
I don't think it makes sense for HTS to handle this sort of error.

Note You need to log in before you can comment on or make changes to this bug.