Bug 480590 - (CVE-2008-4770) CVE-2008-4770 vnc: vncviewer insufficient encoding value validation in CMsgReader::readRect
CVE-2008-4770 vnc: vncviewer insufficient encoding value validation in CMsgRe...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
http://nvd.nist.gov/nvd.cfm?cvename=C...
source=cve,reported=20090116,public=2...
: Security
Depends On: 481331 833987 471777 481328 481329 481330 1017870
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 06:10 EST by Tomas Hoger
Modified: 2013-10-10 12:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-29 04:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Upstream patch (485 bytes, patch)
2009-01-19 06:14 EST, Tomas Hoger
no flags Details | Diff

  None (edit)
Description Tomas Hoger 2009-01-19 06:10:40 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-4770 to the following vulnerability:

The CMsgReader::readRect function in the VNC Viewer component in
RealVNC VNC Free Edition 4.0 through 4.1.2, Enterprise Edition E4.0
through E4.4.2, and Personal Edition P4.0 through P4.4.2 allows remote
VNC servers to execute arbitrary code via crafted RFB protocol data,
related to "encoding type."

References:
http://www.realvnc.com/pipermail/vnc-list/2008-November/059432.html
http://realvnc.com/products/free/4.1/release-notes.html
http://www.realvnc.com/products/upgrade.html
http://xforce.iss.net/xforce/xfdb/47937
http://www.securityfocus.com/bid/33263
http://sunsolve.sun.com/search/document.do?assetkey=1-26-248526-1
Comment 1 Tomas Hoger 2009-01-19 06:14:21 EST
Created attachment 329323 [details]
Upstream patch

Diff of CMsgReader.cxx between 4.1.2 and 4.1.3.
Comment 11 Fedora Update System 2009-01-26 20:50:49 EST
vnc-4.1.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-01-26 20:51:38 EST
vnc-4.1.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.