Bug 480627 - initscripts fail to activate MD on iSCSI
initscripts fail to activate MD on iSCSI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 09:52 EST by Bryn M. Reeves
Modified: 2010-10-23 03:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
add md activation before lvm/device-mapper in netfs
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:13:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add md activation before lvm/device-mapper in netfs (618 bytes, patch)
2009-01-19 09:54 EST, Bryn M. Reeves
no flags Details | Diff

  None (edit)
Description Bryn M. Reeves 2009-01-19 09:52:58 EST
Description of problem:
After configuring an MD array consisting of iSCSI member devices the array does not start automatically following a reboot. The iscsi initiator service does not activate RAID/LVM/etc. itself and has not started by the time the MD activation in rc.sysinit runs. Currently the netfs service can be used to activate LVM/multipath devices using iSCSI but does not currently support MD activation.

Version-Release number of selected component (if applicable):
initscripts-8.45.19.EL-1

How reproducible:
100%

Steps to Reproduce:
1. Configure some iSCSI devices
2. Create an MD array using these devices & verify it works
3. Reboot
  
Actual results:
MD array not started automatically. Manually performing an auto run with mdadm brings the array online.

Expected results:
Array starts automatically.

Additional info:
Comment 1 Bryn M. Reeves 2009-01-19 09:53:38 EST
Filing this against initscripts seemed reasonable as LVM/multipath etc. are handled by netfs but not currently md - let me know if that's wrong & I'll move to iscsi-initiator-utils.
Comment 2 Bryn M. Reeves 2009-01-19 09:54:18 EST
Created attachment 329348 [details]
add md activation before lvm/device-mapper in netfs

add md activation before lvm/device-mapper in netfs, as is currently done in rc.sysinit
Comment 3 Bill Nottingham 2009-01-19 14:35:19 EST
I'm not sure that we technically 'support' RAID over iscsi; AFAIK, we've told people to use DM in this situation.
Comment 4 Bryn M. Reeves 2009-01-19 14:38:52 EST
Wasn't it a user who wanted to use MD over DM that we told to go away? That seems reasonable since the ordering is all wrong for it (and doing it right involves nasty loops until you're sure you're at a leaf device).

This is only a very minor change (and matches the current activation flow in rc.sysinit).
Comment 6 Bill Nottingham 2009-01-19 14:43:51 EST
Hm, anaconda will let you set it up that way, so we should make sure it works.

Oh, for the glorious future where we can just do this all cleanly on-demand via udev.
Comment 7 Bill Nottingham 2009-03-11 13:11:28 EDT
Moving to 5.4, since we're already doing initscripts there.
Comment 9 Harald Hoyer 2009-05-05 08:52:14 EDT
Please test the erratum candidate:
http://people.redhat.com/harald/downloads/initscripts/initscripts-8.45.26.1.el5/
Comment 11 Chris Ward 2009-07-03 14:21:18 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 14 Ryan Lerch 2009-08-04 22:20:00 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
add md activation before lvm/device-mapper in netfs
Comment 15 errata-xmlrpc 2009-09-02 07:13:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1344.html

Note You need to log in before you can comment on or make changes to this bug.