Bug 480628 - RHN PRoxy Kickstart Issue with Clustering, Cluster Storage and Virtualization Software
RHN PRoxy Kickstart Issue with Clustering, Cluster Storage and Virtualization...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
510
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Miroslav Suchý
:
Depends On:
Blocks: 456999 457075 516875
  Show dependency treegraph
 
Reported: 2009-01-19 09:56 EST by Dave Sullivan
Modified: 2009-09-10 10:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 516875 (view as bug list)
Environment:
Last Closed: 2009-09-10 10:37:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Sullivan 2009-01-19 09:56:50 EST
Description of problem:

Not able to install Clustering, Cluster Storage, and Virtualization software doing a bare metal install of a clien through RHN Proxy to RHN Satellite.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure RHN Proxy and RHN Satellite
2. Satellite sync the rhel 5 x86_64 and the child channels for virtualization, clustering, and cluster storage
3. Create a kickstart profile and within the software section add @ Clustering, @ Cluster Storage, and @ Virtualization
4. Kickstart client system using RHN Proxy as the linux ks=http://<your-rhn-proxy>/kickstart/label/<your-ks-profile>
  
Actual results:

Not able to find clustering, cluster storage, or virtualization software

Expected results:

Additional info:

This same kickstart worked fine when going directly to the Satellite Server. (linux ks=http://<your-satellite-server>/kickstart/label/your-ks-profile>

Basically it seem as though the kickstart trees for these groups do not come down to the rhn proxy.

Did a work around and decided to take a different approach and make use of the Activation Keys linked to the clustering, cluster storage, and virtualization channels.  Use this method to individually add required packages from each of these channels.
Comment 2 Justin Sherrill 2009-05-15 19:45:36 EDT
Looks like it works for me moving to modified.
Comment 3 Miroslav Suchý 2009-07-15 11:51:38 EDT
I got the same output from sat and from proxy. And machine kickstart with given channels and @pragmas from both sat and from proxy.
VERIFIED
Comment 4 Preethi Thomas 2009-08-07 13:09:09 EDT
This is fails_qa
tested on 
https://sun-x4200-01.rhts.bos.redhat.com/
tested with proxy & without proxy
have the clustering, cluster storage and virtualization channels subscribed in the ks-script and for the client.

Also tried individual groups
@ Cluster Storage
@ Clustering
@ Virtualization
  +----------------------+ Missing Group +-----------------------+        
        |                                                              |        
        | You have specified that the group 'Cluster Storage' should   |        
        | be installed. This group does not exist. Would you like to   |        
        | continue or abort your installation?                         |        
        |                                                              |        
        |          +-------+                    +----------+           |        
        |          | Abort |                    | Continue |           |        
        |          +-------+                    +----------+           |        
        |                                                              |        
        |                                                              |        
        +--------------------------------------------------------------+
Comment 5 Justin Sherrill 2009-08-11 14:56:21 EDT
 bugzilla 516875 was opened since this is reproducible without a proxy.  I am not able to reproduce on my Dev Workstation but will try with test1182.  Moving this to assigned...
Comment 6 Justin Sherrill 2009-08-11 16:24:08 EDT
So there were 2 reasons this was failing:

1.  The Cluster and ClusterStorage repos were not enabled.  They must be enabled on the Operating System tab of the kickstart

2.  I believe Virtualization was failing because you were trying to do this on a Virt Guest.  It works fine for me on test1182 so that's the only thing i can think of.
Comment 7 Justin Sherrill 2009-08-11 16:42:51 EDT
also it's @ Clustering    not @ Cluster  

@ Cluster will not work :}
Comment 8 Preethi Thomas 2009-08-12 07:59:10 EDT
My mistake.
This is working
tested it on rlx-0-14 (webqa) and 
https://sun-x4200-01.rhts.bos.redhat.com (stage)
Clustering and Cluster Storage package groups installed when kickstarting systems through proxy.
Comment 9 Preethi Thomas 2009-08-12 07:59:52 EDT
Release Pending
https://sun-x4200-01.rhts.bos.redhat.com (stage)
Comment 10 Brandon Perkins 2009-09-10 10:37:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.