Bug 480637 - deluge: Duplication of system libraries
deluge: Duplication of system libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 10:53 EST by Alexey Kuznetsov
Modified: 2009-01-19 13:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 13:36:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2009-01-19 10:53:30 EST
https://fedoraproject.org/wiki/Packaging/Guidelines#Duplication_of_system_libraries


[axet@axet-laptop deluge]$ rpm -qil deluge|grep libtor
/usr/lib/python2.5/site-packages/deluge/libtorrent.so
Comment 1 Peter Gordon 2009-01-19 13:36:57 EST
I fixed this about two weeks ago in Rawhide; but keeping it built against an internal copy of libtorrent in Fedora 9/10 is a necessary evil at this point. Deluge *requires* the 0.14 series of libtorrent at minimum for its functionality. (In fact, I just tried it with a system copy of libtorrent .13 and it simply hangs on starting the daemon.)

However, the upgrade from rb_libtorrent 0.13 to 0.14 changes the API/ABI and breaks backward-compatibility, so it is only in Rawhide at this time. In fact, Deluge in Rawhide *is* using the system copy of rb_libtorrent, so this is no longer an issue there. See: https://www.redhat.com/archives/fedora-devel-list/2009-January/msg00373.html

It is that older Fedora releases are using such old versions of libtorrent which causes Deluge to require its own internal (far newer) copy. And upgrading those Fedora releases with the newer libtorrent is a definite no-go at this point in time, due to these compatibility-breaking changes.

Apologies for any inconvenience this may cause! 

Thanks for the bug report; and please feel free to re-open this with more details if you have any further questions or comments, et al. :)

Note You need to log in before you can comment on or make changes to this bug.