Bug 480645 - Spacewalk 0.4: Missing "tid" parameter in AddSystems and ListRemoveSystems requests causes error
Spacewalk 0.4: Missing "tid" parameter in AddSystems and ListRemoveSystems re...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-01-19 11:56 EST by Brian Beaudoin
Modified: 2009-06-23 13:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 13:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback from request (5.79 KB, text/plain)
2009-01-19 11:57 EST, Brian Beaudoin
no flags Details

  None (edit)
Description Brian Beaudoin 2009-01-19 11:56:26 EST
Description of problem:

When following either the "Systems" or "Target Systems" links from the System Group Details page (https://spacewalk.peer1.net/network/systems/groups/details.pxt?sgid=10) the following error is returned:

    Page Request Error

    We could not display the requested page because of a missing
    parameter. This error could have occured several ways:

       1. An incorrect or out-of-date bookmark.
       2. An incorrect or out-of-date hyperlink.
       3. Your browser encountered an error handling request
          parameters. Continued use of this browser may yield
          unexpected results.
       4. You've found an error in our site. Please help us by
          filling out this form with details of how you received
          this message.

The web traceback states "The parameter tid is required."


Version-Release number of selected component (if applicable):

    Spacewalk 0.4


How reproducible:

Go to System Groups, select a group, and select either the "Systems" or "Target Systems" links.


Expected results:

Spacewalk should provide the correct number of parameters with appropriate values according to the request made.  In layman's terms, the request should complete without error.


Additional info:

Adding "&tid=0" to the request will bring up the requested page without error.  Using the "Work with group" link is another work-around until these links are corrected.
Comment 1 Brian Beaudoin 2009-01-19 11:57:03 EST
Created attachment 329365 [details]
Traceback from request
Comment 2 Brian Beaudoin 2009-06-23 13:31:23 EDT
This bug does not exist in Spacewalk 0.5.  Closing with status "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.