Bug 480647 - UDEV eth assignments not working
UDEV eth assignments not working
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: zenity (Show other bugs)
5.2
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 12:05 EST by Dave Sullivan
Modified: 2014-09-22 09:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Sullivan 2009-01-19 12:05:43 EST
Description of problem:

RHEL5u2x86 running Xen Kernel

Udev rules do not appear to work.  The current system consists of HP DL380 with 2 onboard Broadcom NICs and two dual port external e1000 NICs.

When trying to set up udev rules to order the eth interfaces apparently the udev rules were not working.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install RHE5u2x86_64
2. Install Xen Kernel
3. Create udev rules

To prevent the ethernet interface from switching when adding new network card hardware,
create and use an additional udev rule at every cluster node which maintains interfaces to
MAC addresses.
[/etc/udev/rules.d/70custom.
rules]
ACTION=="add", KERNEL=="eth*", SYSFS{address}=="00:16:55:81:EF:C0", NAME="eth0"
ACTION=="add", KERNEL=="eth*", SYSFS{address}=="00:16:55:81:EF:A3”, NAME="eth1"
ACTION=="add", KERNEL=="eth*", SYSFS{address}=="00:16:55:81:EF:E4", NAME="eth2"
ACTION=="add", KERNEL=="eth*", SYSFS{address}=="00:16:55:81:EF:B1”, NAME="eth3"
  
Actual results:

Did not appear to work.

Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2014-03-07 07:51:12 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:20:48 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 4 Dave Sullivan 2014-09-22 09:50:46 EDT
clearing need info, NA

Note You need to log in before you can comment on or make changes to this bug.