Bug 480679 - integrate latest selinux code with the rest of the build infrastructure
integrate latest selinux code with the rest of the build infrastructure
Status: CLOSED CURRENTRELEASE
Product: Dogtag Certificate System
Classification: Community
Component: Build (Show other bugs)
1.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Ade Lee
Chandrasekar Kannan
:
: 480680 (view as bug list)
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-01-19 14:45 EST by Ade Lee
Modified: 2015-01-04 18:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 11:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Lee 2009-01-19 14:45:01 EST
Description of problem:
Latest selinux code has been checked into :
Adding         base/selinux
Adding         base/selinux/src
Adding         base/selinux/src/pki.fc
Adding         base/selinux/src/pki.if
Adding         base/selinux/src/pki.sh
Adding         base/selinux/src/pki.te
Adding         dogtag/selinux
Adding         dogtag/selinux/config
Adding         dogtag/selinux/pki-selinux.spec

But needs all the other goodies, to do the build correctly and make the rpm.  The checked in spec file is only a template.  When the rest of the build is in place, I will tweak to fix accordingly.

The build consists of cd'ing into the base/selinux/src directory and running pki.sh.  This will call make -- and generate a policy module pki.pp 

This policy module is what needs to be delivered to the directory /user/share/selinux/targeted.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Harmsen 2009-01-19 17:20:12 EST
(1) Place svn:externals properties into pki/base/selinux:

% cd pki/base/selinux
Create a temporary file called "x" which contains the following line:

    config https://pki.fedoraproject.org/svn/pki/trunk/pki/base/config

% svn propset svn:externals -F ./x .
property 'svn:externals' set on '.'

% rm ./x
% svn propget svn:externals .
config https://pki.fedoraproject.org/svn/pki/trunk/pki/base/config

% svn update

Fetching external item into 'config'
A    config/product.xml
A    config/release.xml
Updated external to revision 172.

Updated to revision 172.

% svn commit
Sending        selinux

Committed revision 175.
NOTE:  Had previous committed the stuff in step (2) below.

(2) Remove the dogtag/selinux/config directory so that it may be replaced by
    svn:externals properties:

% cd dogtag/selinux
% svn rm config
% svn commit

% cd dogtag/scripts
% svn diff set_dogtag_SVN_external_properties
Index: set_dogtag_SVN_external_properties
===================================================================
--- set_dogtag_SVN_external_properties  (revision 172)
+++ set_dogtag_SVN_external_properties  (working copy)
@@ -26,7 +26,7 @@
 # Specify the location and a list of the SVN components that
 # require these SVN external properties to be updated.
 SVN_COMPONENTS_LOCATION="${PKI_PWD}/.."
-SVN_COMPONENTS="ca ca-ui common common-ui console console-ui java-tools kra kra-ui manage migrate native-tools ocsp ocsp-ui osutil ra ra-ui setup silent symkey tks tks-ui tps tps-ui util"
+SVN_COMPONENTS="ca ca-ui common common-ui console console-ui java-tools kra kra-ui manage migrate native-tools ocsp ocsp-ui osutil ra ra-ui selinux setup silent symkey tks tks-ui tps tps-ui util"
 
 # Change directory to the location of all of these components,
 # and execute the defined SVN external property changes.

% svn commit
Sending        scripts/set_dogtag_SVN_external_properties
Transmitting file data .
Committed revision 173.

% ./set_dogtag_SVN_external_properties

% cd pki/dogtag/selinux
% svn status
X      config-ext
X      config
 M     .

Performing status on external item at 'config'

Performing status on external item at 'config-ext'
% svn commit
Sending        selinux

Committed revision 174.
Comment 2 Matthew Harmsen 2009-01-20 20:58:31 EST
Create the build infrastructure files in the "pki/base/selinux" directory:

A      base/selinux/LICENSE
A      base/selinux/build.xml

svn commit
Adding         base/selinux/LICENSE
Adding         base/selinux/build.xml
Transmitting file data ..
Committed revision 177.


Create the new build infrastructure files in the "pki/dogtag/selinux" directory:

A      dogtag/selinux/build_dogtag

svn commit
Adding         dogtag/selinux/build_dogtag
Transmitting file data .
Committed revision 178.


Update the "pki-selinux.spec" file in the "pki/dogtag/selinux" directory:

svn diff dogtag/selinux/pki-selinux.spec 
Index: dogtag/selinux/pki-selinux.spec
===================================================================
--- dogtag/selinux/pki-selinux.spec     (revision 176)
+++ dogtag/selinux/pki-selinux.spec     (working copy)
@@ -33,7 +33,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      1
+%define base_release      2
 %define base_group        System Environment/Shells
 %define base_vendor       Red Hat, Inc.
 %define base_license      GPLv2 with exceptions
@@ -142,7 +142,7 @@
 %prep
 
 
-%setup -q
+%setup -q -n %{base_name}-%{base_version}
 
 
 ## This package currently contains no patches!
@@ -156,7 +156,8 @@
 ###############################################################################
 
 %build
-ant -Dspecfile=%{base_name}.spec
+cd src
+make
 
 
 
@@ -165,8 +166,11 @@
 ###############################################################################
 
 %install
-cd dist/binary
-unzip %{name}-%{version}.zip -d ${RPM_BUILD_ROOT}
+rm -rf ${RPM_BUILD_ROOT}
+mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/doc/%{base_name}-%{base_version}
+cp -p LICENSE ${RPM_BUILD_ROOT}%{_datadir}/doc/%{base_name}-%{base_version}
+mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/selinux/targeted
+cp -p src/pki.pp ${RPM_BUILD_ROOT}%{_datadir}/selinux/targeted
 
 
 
@@ -224,7 +228,8 @@
 ###############################################################################
 
 %files
-%{_usr}/share/selinux/targeted/pki.pp
+%attr(-,root,root)     %{_datadir}/doc/%{base_name}-%{base_version}/*
+%attr(-,root,root)     %{_datadir}/selinux/targeted/pki.pp
 
 
 
@@ -233,7 +238,10 @@
 ###############################################################################
 
 %changelog
-* Mon Jan 16 2009 Ade Lee <alee@redhat.com> 1.0.0-1
+* Tue Jan 20 2009 Matthew Harmsen <mharmsen@redhat.com> 1.0.0-2
+- Bugzilla Bug #480679 - integrate latest selinux code with the rest
+  of the build infrastructure 
+
+* Mon Jan 19 2009 Ade Lee <alee@redhat.com> 1.0.0-1
 - Initial release

svn commit
Sending        dogtag/selinux/pki-selinux.spec
Transmitting file data .
Committed revision 179.
Comment 4 Matthew Harmsen 2009-01-20 21:09:05 EST
Above, the appropriate way to change SVN external properties was to fix the "base" script provided for doing this:

svn diff base/scripts/set_base_SVN_external_properties
Index: base/scripts/set_base_SVN_external_properties
===================================================================
--- base/scripts/set_base_SVN_external_properties       (revision 176)
+++ base/scripts/set_base_SVN_external_properties       (working copy)
@@ -26,7 +26,7 @@
 # Specify the location and a list of the SVN components that
 # require these SVN external properties to be updated.
 SVN_COMPONENTS_LOCATION="${PKI_PWD}/.."
-SVN_COMPONENTS="ca common console java-tools kra manage migrate native-tools ocsp osutil ra setup silent symkey tks tps util"
+SVN_COMPONENTS="ca common console java-tools kra manage migrate native-tools ocsp osutil ra setup selinux silent symkey tks tps util"
 
 # Change directory to the location of all of these components,
 # and execute the defined SVN external property changes.

svn commit
Sending        base/scripts/set_base_SVN_external_properties
Transmitting file data .
Committed revision 180.
Comment 5 Matthew Harmsen 2009-01-20 21:22:35 EST
Update build scripts to include the new "pki-selinux" component:

M      dogtag/scripts/build_ca
M      dogtag/scripts/build_pki

NOTE:  Since the "pki-selinux" component begins with "pki-", the
       "dogtag/scripts/remove_pki_components" script does NOT need
       to be changed!

svn diff
Index: dogtag/scripts/build_ca
===================================================================
--- dogtag/scripts/build_ca     (revision 176)
+++ dogtag/scripts/build_ca     (working copy)
@@ -102,6 +102,7 @@
 PKI_COMMON_UI=${PKI_FLAVOR}-pki-common-ui${RPM_EXT}
 PKI_COMMON=pki-common${RPM_EXT}
 PKI_COMMON_JAVADOC=pki-common-javadoc${RPM_EXT}
+PKI_SELINUX=pki-selinux${RPM_EXT}
 
 # Establish PKI subsystem package names
 PKI_CA_UI=${PKI_FLAVOR}-pki-ca-ui${RPM_EXT}
@@ -151,6 +152,10 @@
 ${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_DIR}/common/${RPM_DIR}/${PKI_COMMON}
 ${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_DIR}/common/${RPM_DIR}/${PKI_COMMON_JAVADOC}
 
+# Build and install 'pki-selinux' packages
+${PKI_BUILD_SCRIPT_DIR}/selinux/${PKI_BUILD_SCRIPT}
+${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_DIR}/selinux/${RPM_DIR}/${PKI_SELINUX}
+
 # Build and install 'pki-ca-ui' packages
 ${PKI_BUILD_SCRIPT_DIR}/ca-ui/${PKI_BUILD_SCRIPT}
 ${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_UI_DIR}/ca-ui/${RPM_DIR}/${PKI_CA_UI}
Index: dogtag/scripts/build_pki
===================================================================
--- dogtag/scripts/build_pki    (revision 176)
+++ dogtag/scripts/build_pki    (working copy)
@@ -102,6 +102,7 @@
 PKI_COMMON_UI=${PKI_FLAVOR}-pki-common-ui${RPM_EXT}
 PKI_COMMON=pki-common${RPM_EXT}
 PKI_COMMON_JAVADOC=pki-common-javadoc${RPM_EXT}
+PKI_SELINUX=pki-selinux${RPM_EXT}
 
 # Establish PKI subsystem package names
 PKI_CA_UI=${PKI_FLAVOR}-pki-ca-ui${RPM_EXT}
@@ -163,6 +164,10 @@
 ${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_DIR}/common/${RPM_DIR}/${PKI_COMMON}
 ${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_DIR}/common/${RPM_DIR}/${PKI_COMMON_JAVADOC}
 
+# Build and install 'pki-selinux' packages
+${PKI_BUILD_SCRIPT_DIR}/selinux/${PKI_BUILD_SCRIPT}
+${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_DIR}/selinux/${RPM_DIR}/${PKI_SELINUX}
+
 # Build and install 'pki-ca-ui' packages
 ${PKI_BUILD_SCRIPT_DIR}/ca-ui/${PKI_BUILD_SCRIPT}
 ${PKI_SUDO} ${RPM_EXE} ${RPM_EXE_OPTIONS} ${PKI_RELEASE_UI_DIR}/ca-ui/${RPM_DIR}/${PKI_CA_UI}


svn status
Sending        dogtag/scripts/build_ca
Sending        dogtag/scripts/build_pki
Transmitting file data ..
Committed revision 181.
Comment 12 Ade Lee 2009-01-27 12:19:31 EST
[builder@dhcp231-124 dogtag]$ svn diff -r 193
Index: ca/pki-ca.spec
===================================================================
--- ca/pki-ca.spec      (revision 193)
+++ ca/pki-ca.spec      (working copy)
@@ -34,7 +34,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      20
+%define base_release      21
 %define base_group        System Environment/Daemons
 %define base_vendor       Red Hat, Inc.
 %define base_license      GPLv2 with exceptions
@@ -131,7 +131,7 @@
 BuildRequires:  ant >= 1.6.2, %{base_flavor}-%{base_name}-ui >= 1.0.0, %{base_prefix}-common >= 1.0.0, %{base_prefix}-util >= 1.0.0, java-devel >= 1.6.0, jpackage-utils >= 1.6.0, jss >= 4.2.4
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0
+Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0, %{base_prefix}-selinux >= 1.0.0
 
 
 ## This package is non-relocatable!
@@ -278,6 +278,8 @@
 ###############################################################################
 
 %changelog
+* Tue Jan 27 2009 Ade Lee <alee@redhat.com> 1.0.0-21
+- Bugzilla Bug 480679 - Integrate selinux into framework
 * Thu Jan 22 2009 Christina Fu <cfu@redhat.com> 1.0.0-20
 - Bugzilla Bug 481237 - Audit Log signing framework
 * Mon Jan 5 2009 Ade Lee <alee@redhat.com> 1.0.0-19
Index: tks/pki-tks.spec
===================================================================
--- tks/pki-tks.spec    (revision 193)
+++ tks/pki-tks.spec    (working copy)
@@ -34,7 +34,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      10
+%define base_release      11
 %define base_group        System Environment/Daemons
 %define base_vendor       Red Hat, Inc.
 %define base_license      GPLv2 with exceptions
@@ -131,7 +131,7 @@
 BuildRequires:  ant >= 1.6.2, %{base_flavor}-%{base_name}-ui >= 1.0.0, %{base_prefix}-common >= 1.0.0, %{base_prefix}-util >= 1.0.0, java-devel >= 1.6.0, jpackage-utils >= 1.6.0, jss >= 4.2.4
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0
+Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0, %{base_prefix}-selinux >= 1.0.0
 
 
 ## This package is non-relocatable!
@@ -287,6 +287,8 @@
 ###############################################################################
 
 %changelog
+* Tue Jan 27 2009 Ade Lee <alee@redhat.com> 1.0.0-11
+- Bugzilla Bug 480679 - Integrate selinux into framework
 * Thu Jan 22 2009 Christina Fu <cfu@redhat.com> 1.0.0-10
 - Bugzilla Bug 481237 - Audit Log signing framework
 * Mon Jan 5 2009 Ade Lee <alee@redhat.com> 1.0.0-9
Index: ra/pki-ra.spec
===================================================================
--- ra/pki-ra.spec      (revision 193)
+++ ra/pki-ra.spec      (working copy)
@@ -34,7 +34,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      10
+%define base_release      11
 %define base_group        System Environment/Daemons
 %define base_vendor       Red Hat, Inc.
 %define base_license      GPLv2 with exceptions
@@ -124,7 +124,7 @@
 BuildRequires:  ant >= 1.6.2, %{base_flavor}-%{base_name}-ui >= 1.0.0
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_name}-ui, %{base_prefix}-setup >= 1.0.0, mod_nss >= 1.0.3, mod_perl >= 1.99_16, mozldap >= 6.0.2, perl-DBD-SQLite >= 1.11, perl-DBI >= 1.52, perl-HTML-Parser >= 3.35, perl-HTML-Tagset >= 3.03, perl-Parse-RecDescent >= 1.94, perl-URI >= 1.30, perl-XML-NamespaceSupport >= 1.08, perl-XML-Parser >= 2.34, perl-XML-SAX >= 0.12, sendmail >= 8.13.1, sqlite >= 3.3.3
+Requires:       %{base_name}-ui, %{base_prefix}-setup >= 1.0.0, mod_nss >= 1.0.3, mod_perl >= 1.99_16, mozldap >= 6.0.2, perl-DBD-SQLite >= 1.11, perl-DBI >= 1.52, perl-HTML-Parser >= 3.35, perl-HTML-Tagset >= 3.03, perl-Parse-RecDescent >= 1.94, perl-URI >= 1.30, perl-XML-NamespaceSupport >= 1.08, perl-XML-Parser >= 2.34, perl-XML-SAX >= 0.12, sendmail >= 8.13.1, sqlite >= 3.3.3, %{base_prefix}-selinux >= 1.0.0
 
 
 ## This package is non-relocatable!
@@ -261,6 +261,8 @@
 ###############################################################################
 
 %changelog
+* Tue Jan 27 2009 Ade Lee <alee@redhat.com> 1.0.0-11
+- Bugzilla Bug 480679 - Integrate selinux into framework
 * Thu Jan 22 2009 Matthew Harmsen <mharmsen@redhat.com> 1.0.0-10
 - Bugzilla Bug #480952 - moved "perl-XML-Simple" and "perl-libwww-perl"
   runtime dependencies to pki-setup
Index: ocsp/pki-ocsp.spec
===================================================================
--- ocsp/pki-ocsp.spec  (revision 193)
+++ ocsp/pki-ocsp.spec  (working copy)
@@ -34,7 +34,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      10
+%define base_release      11
 %define base_group        System Environment/Daemons
 %define base_vendor       Red Hat, Inc.
 %define base_license      GPLv2 with exceptions
@@ -131,7 +131,7 @@
 BuildRequires:  ant >= 1.6.2, %{base_flavor}-%{base_name}-ui >= 1.0.0, %{base_prefix}-common >= 1.0.0, %{base_prefix}-util >= 1.0.0, java-devel >= 1.6.0, jpackage-utils >= 1.6.0, jss >= 4.2.4
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0
+Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0, %{base_prefix}-selinux >= 1.0.0
 
 
 ## This package is non-relocatable!
@@ -294,6 +294,8 @@
 ###############################################################################
 
 %changelog
+* Tue Jan 27 2009 Ade Lee <alee@redhat.com> 1.0.0-11
+- Bugzilla Bug 480679 - Integrate selinux into framework
 * Thu Jan 22 2009 Christina Fu <cfu@redhat.com> 1.0.0-10
 - Bugzilla Bug 481237 - Audit Log signing framework
 * Mon Jan 5 2009 Ade Lee <alee@redhat.com> 1.0.0-9
Index: tps/pki-tps.spec
===================================================================
--- tps/pki-tps.spec    (revision 193)
+++ tps/pki-tps.spec    (working copy)
@@ -34,7 +34,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      14
+%define base_release      15
 %define base_group        System Environment/Daemons
 %define base_vendor       Red Hat, Inc.
 %define base_license      LGPLv2 with exceptions
@@ -146,7 +146,7 @@
 BuildRequires:  apr-devel >= 0.9.4, apr-util-devel >= 0.9.4, %{base_flavor}-%{base_name}-ui >= 1.0.0, bash >= 3.0, cyrus-sasl-devel >= 2.1.19, httpd-devel >= 2.0.52, mozldap-devel >= 6.0.2, nspr-devel >= 4.6.99, nss-devel >= 3.12.0, pcre-devel >= 6.6, svrcore-devel >= 4.0.3.01, zlib >= 1.2.3
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_prefix}-setup >= 1.0.0, %{base_name}-ui, mod_nss >= 1.0.3, mod_perl >= 1.99_16, mozldap >= 6.0.2, perl-HTML-Parser >= 3.35, perl-HTML-Tagset >= 3.03, perl-Parse-RecDescent >= 1.94, perl-URI >= 1.30, perl-XML-NamespaceSupport >= 1.08, perl-XML-Parser >= 2.34, perl-XML-SAX >= 0.12
+Requires:       %{base_prefix}-setup >= 1.0.0, %{base_name}-ui, mod_nss >= 1.0.3, mod_perl >= 1.99_16, mozldap >= 6.0.2, perl-HTML-Parser >= 3.35, perl-HTML-Tagset >= 3.03, perl-Parse-RecDescent >= 1.94, perl-URI >= 1.30, perl-XML-NamespaceSupport >= 1.08, perl-XML-Parser >= 2.34, perl-XML-SAX >= 0.12, %{base_prefix}-selinux >= 1.0.0
 
 
 ## This package is non-relocatable!
@@ -308,6 +308,8 @@
 ###############################################################################
 
 %changelog
+* Tue Jan 27 2009 Ade Lee <alee@redhat.com> 1.0.0-15
+- Bugzilla Bug 480679 - Integrate selinux into framework
 * Thu Jan 23 2009 Jack Magne <jmagne@redhat.com> 1.0.0-14
 - Bugzilla Bug #459539 - Support safenet 330J token.
 * Thu Jan 22 2009 Matthew Harmsen <mharmsen@redhat.com> 1.0.0-13
Index: kra/pki-kra.spec
===================================================================
--- kra/pki-kra.spec    (revision 193)
+++ kra/pki-kra.spec    (working copy)
@@ -34,7 +34,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      11
+%define base_release      12
 %define base_group        System Environment/Daemons
 %define base_vendor       Red Hat, Inc.
 %define base_license      GPLv2 with exceptions
@@ -131,7 +131,7 @@
 BuildRequires:  ant >= 1.6.2, %{base_flavor}-%{base_name}-ui >= 1.0.0, %{base_prefix}-common >= 1.0.0, %{base_prefix}-util >= 1.0.0, java-devel >= 1.6.0, jpackage-utils >= 1.6.0, jss >= 4.2.4
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0
+Requires:       %{base_name}-ui, %{base_prefix}-common >= 1.0.0, %{base_prefix}-selinux >= 1.0.0
 
 
 ## This package is non-relocatable!
@@ -285,6 +285,8 @@
 ###############################################################################
 
 %changelog
+* Tue Jan 27 2009 Ade Lee <alee@redhat.com> 1.0.0-12
+- Bugzilla Bug 480679 - Integrate selinux into framework
 * Thu Jan 22 2009 Christina Fu <cfu@redhat.com> 1.0.0-11
 - Bugzilla Bug 481237 - Audit Log signing framework
 * Mon Jan 5 2009 Ade Lee <alee@redhat.com> 1.0.0-10

Committed in:
[builder@dhcp231-124 dogtag]$ svn ci -m "Bugzilla BZ 480679: integrate selinux components into build"
Sending        dogtag/ca/pki-ca.spec
Sending        dogtag/kra/pki-kra.spec
Sending        dogtag/ocsp/pki-ocsp.spec
Sending        dogtag/ra/pki-ra.spec
Sending        dogtag/tks/pki-tks.spec
Sending        dogtag/tps/pki-tps.spec
Transmitting file data ......
Committed revision 194.
Comment 14 Matthew Harmsen 2009-01-27 13:05:37 EST
Dogtag Preparation Scripts:

% svn diff

Index: dogtag/scripts/prepare_ca
===================================================================
--- dogtag/scripts/prepare_ca   (revision 194)
+++ dogtag/scripts/prepare_ca   (working copy)
@@ -146,7 +146,11 @@
 IDM_CONSOLE_FRAMEWORK=idm-console-framework
 TOMCAT5=tomcat5
 TOMCATJSS=tomcatjss
+MAKE=make
+M4=m4
+POLICYCOREUTILS=policycoreutils
+SELINUX_POLICY_DEVEL=selinux-policy-devel
 
 # Build and install PKI support packages
-${PKI_SUDO} ${PKI_UPDATE} ${PKI_UPDATE_OPTIONS} ${NSPR} ${NSPR_DEVEL} ${NSS} ${NSS_DEVEL} ${NSS_TOOLS} ${JSS} ${SVRCORE} ${SVRCORE_DEVEL} ${CYRUS_SASL} ${CYRUS_SASL_DEVEL} ${MOZLDAP} ${MOZLDAP_DEVEL} ${MOZLDAP_TOOLS} ${PERL} ${JPACKAGE_UTILS} ${JAKARTA_COMMONS_LOGGING} ${TOMCAT5_SERVLET_2_4_API} ${JAKARTA_COMMONS_COLLECTIONS} ${JAKARTA_COMMONS_BEANUTILS} ${JAKARTA_COMMONS_DIGESTER} ${ORO} ${CLASSPATHX_JAF} ${LDAPJDK} ${JAKARTA_COMMONS_POOL} ${JAKARTA_COMMONS_FILEUPLOAD} ${XML_COMMONS} ${XML_COMMONS_APIS} ${REGEXP} ${BCEL} ${JAKARTA_COMMONS_DBCP} ${TOMCAT5_JASPER} ${JAKARTA_COMMONS_DISCOVERY} ${JAKARTA_COMMONS_HTTPCLIENT3} ${JMS} ${JAKARTA_COMMONS_LAUNCHER} ${JAKARTA_COMMONS_EL} ${JAKARTA_COMMONS_DAEMON} ${GNU_CRYPTO_SASL_JDK1_4} ${CLASSPATHX_MAIL} ${XERCES_J2} ${XALAN_J2} ${LOG4J} ${XML_COMMONS_RESOLVER} ${AVALON_LOGKIT} ${AVALON_FRAMEWORK} ${JDOM} ${WERKEN_XPATH} ${VELOCITY} ${ANT} ${WSDL4J} ${AXIS} ${MX4J} ${GERONIMO_SPECS} ${JAKARTA_COMMONS_MODELER} ${IDM_CONSOLE_FRAMEWORK} ${TOMCAT5} ${TOMCATJSS}
+${PKI_SUDO} ${PKI_UPDATE} ${PKI_UPDATE_OPTIONS} ${NSPR} ${NSPR_DEVEL} ${NSS} ${NSS_DEVEL} ${NSS_TOOLS} ${JSS} ${SVRCORE} ${SVRCORE_DEVEL} ${CYRUS_SASL} ${CYRUS_SASL_DEVEL} ${MOZLDAP} ${MOZLDAP_DEVEL} ${MOZLDAP_TOOLS} ${PERL} ${JPACKAGE_UTILS} ${JAKARTA_COMMONS_LOGGING} ${TOMCAT5_SERVLET_2_4_API} ${JAKARTA_COMMONS_COLLECTIONS} ${JAKARTA_COMMONS_BEANUTILS} ${JAKARTA_COMMONS_DIGESTER} ${ORO} ${CLASSPATHX_JAF} ${LDAPJDK} ${JAKARTA_COMMONS_POOL} ${JAKARTA_COMMONS_FILEUPLOAD} ${XML_COMMONS} ${XML_COMMONS_APIS} ${REGEXP} ${BCEL} ${JAKARTA_COMMONS_DBCP} ${TOMCAT5_JASPER} ${JAKARTA_COMMONS_DISCOVERY} ${JAKARTA_COMMONS_HTTPCLIENT3} ${JMS} ${JAKARTA_COMMONS_LAUNCHER} ${JAKARTA_COMMONS_EL} ${JAKARTA_COMMONS_DAEMON} ${GNU_CRYPTO_SASL_JDK1_4} ${CLASSPATHX_MAIL} ${XERCES_J2} ${XALAN_J2} ${LOG4J} ${XML_COMMONS_RESOLVER} ${AVALON_LOGKIT} ${AVALON_FRAMEWORK} ${JDOM} ${WERKEN_XPATH} ${VELOCITY} ${ANT} ${WSDL4J} ${AXIS} ${MX4J} ${GERONIMO_SPECS} ${JAKARTA_COMMONS_MODELER} ${IDM_CONSOLE_FRAMEWORK} ${TOMCAT5} ${TOMCATJSS} ${MAKE} ${M4} ${POLICYCOREUTILS} ${SELINUX_POLICY_DEVEL}
 
Index: dogtag/scripts/prepare_pki
===================================================================
--- dogtag/scripts/prepare_pki  (revision 194)
+++ dogtag/scripts/prepare_pki  (working copy)
@@ -163,6 +163,10 @@
 IDM_CONSOLE_FRAMEWORK=idm-console-framework
 TOMCAT5=tomcat5
 TOMCATJSS=tomcatjss
+MAKE=make
+M4=m4
+POLICYCOREUTILS=policycoreutils
+SELINUX_POLICY_DEVEL=selinux-policy-devel
 READLINE=readline
 READLINE_DEVEL=readline-devel
 NCURSES=ncurses
@@ -180,5 +184,5 @@
 HTTPD_DEVEL=httpd-devel
 
 # Build and install PKI support packages
-${PKI_SUDO} ${PKI_UPDATE} ${PKI_UPDATE_OPTIONS} ${NSPR} ${NSPR_DEVEL} ${NSS} ${NSS_DEVEL} ${NSS_TOOLS} ${JSS} ${SVRCORE} ${SVRCORE_DEVEL} ${CYRUS_SASL} ${CYRUS_SASL_DEVEL} ${MOZLDAP} ${MOZLDAP_DEVEL} ${MOZLDAP_TOOLS} ${PERL} ${APR} ${PCRE} ${EXPAT} ${APR_UTIL} ${HTTPD} ${MOD_NSS} ${MOD_PERL} ${MOD_REVOCATOR} ${PERL_PARSE_RECDESCENT} ${PERL_HTML_TAGSET} ${PERL_HTML_PARSER} ${PERL_URI} ${PERL_LIBWWW_PERL} ${PERL_XML_PARSER} ${PERL_XML_SIMPLE} ${PERL_XML_NAMESPACESUPPORT} ${PERL_XML_SAX} ${JPACKAGE_UTILS} ${JAKARTA_COMMONS_LOGGING} ${TOMCAT5_SERVLET_2_4_API} ${JAKARTA_COMMONS_COLLECTIONS} ${JAKARTA_COMMONS_BEANUTILS} ${JAKARTA_COMMONS_DIGESTER} ${ORO} ${CLASSPATHX_JAF} ${LDAPJDK} ${JAKARTA_COMMONS_POOL} ${JAKARTA_COMMONS_FILEUPLOAD} ${XML_COMMONS} ${XML_COMMONS_APIS} ${REGEXP} ${BCEL} ${JAKARTA_COMMONS_DBCP} ${TOMCAT5_JASPER} ${JAKARTA_COMMONS_DISCOVERY} ${JAKARTA_COMMONS_HTTPCLIENT3} ${JMS} ${JAKARTA_COMMONS_LAUNCHER} ${JAKARTA_COMMONS_EL} ${JAKARTA_COMMONS_DAEMON} ${GNU_CRYPTO_SASL_JDK1_4} ${CLASSPATHX_MAIL} ${XERCES_J2} ${XALAN_J2} ${LOG4J} ${XML_COMMONS_RESOLVER} ${AVALON_LOGKIT} ${AVALON_FRAMEWORK} ${JDOM} ${WERKEN_XPATH} ${VELOCITY} ${ANT} ${WSDL4J} ${AXIS} ${MX4J} ${GERONIMO_SPECS} ${JAKARTA_COMMONS_MODELER} ${IDM_CONSOLE_FRAMEWORK} ${TOMCAT5} ${TOMCATJSS} ${READLINE} ${READLINE_DEVEL} ${NCURSES} ${NCURSES_DEVEL} ${TCL} ${TCL_DEVEL} ${SQLITE} ${SQLITE_DEVEL} ${PERL_DBI} ${PERL_DBD_SQLITE} ${PCRE_DEVEL} ${EXPAT_DEVEL} ${APR_DEVEL} ${APR_UTIL_DEVEL} ${HTTPD_DEVEL}
+${PKI_SUDO} ${PKI_UPDATE} ${PKI_UPDATE_OPTIONS} ${NSPR} ${NSPR_DEVEL} ${NSS} ${NSS_DEVEL} ${NSS_TOOLS} ${JSS} ${SVRCORE} ${SVRCORE_DEVEL} ${CYRUS_SASL} ${CYRUS_SASL_DEVEL} ${MOZLDAP} ${MOZLDAP_DEVEL} ${MOZLDAP_TOOLS} ${PERL} ${APR} ${PCRE} ${EXPAT} ${APR_UTIL} ${HTTPD} ${MOD_NSS} ${MOD_PERL} ${MOD_REVOCATOR} ${PERL_PARSE_RECDESCENT} ${PERL_HTML_TAGSET} ${PERL_HTML_PARSER} ${PERL_URI} ${PERL_LIBWWW_PERL} ${PERL_XML_PARSER} ${PERL_XML_SIMPLE} ${PERL_XML_NAMESPACESUPPORT} ${PERL_XML_SAX} ${JPACKAGE_UTILS} ${JAKARTA_COMMONS_LOGGING} ${TOMCAT5_SERVLET_2_4_API} ${JAKARTA_COMMONS_COLLECTIONS} ${JAKARTA_COMMONS_BEANUTILS} ${JAKARTA_COMMONS_DIGESTER} ${ORO} ${CLASSPATHX_JAF} ${LDAPJDK} ${JAKARTA_COMMONS_POOL} ${JAKARTA_COMMONS_FILEUPLOAD} ${XML_COMMONS} ${XML_COMMONS_APIS} ${REGEXP} ${BCEL} ${JAKARTA_COMMONS_DBCP} ${TOMCAT5_JASPER} ${JAKARTA_COMMONS_DISCOVERY} ${JAKARTA_COMMONS_HTTPCLIENT3} ${JMS} ${JAKARTA_COMMONS_LAUNCHER} ${JAKARTA_COMMONS_EL} ${JAKARTA_COMMONS_DAEMON} ${GNU_CRYPTO_SASL_JDK1_4} ${CLASSPATHX_MAIL} ${XERCES_J2} ${XALAN_J2} ${LOG4J} ${XML_COMMONS_RESOLVER} ${AVALON_LOGKIT} ${AVALON_FRAMEWORK} ${JDOM} ${WERKEN_XPATH} ${VELOCITY} ${ANT} ${WSDL4J} ${AXIS} ${MX4J} ${GERONIMO_SPECS} ${JAKARTA_COMMONS_MODELER} ${IDM_CONSOLE_FRAMEWORK} ${TOMCAT5} ${TOMCATJSS} ${MAKE} ${M4} ${POLICYCOREUTILS} ${SELINUX_POLICY_DEVEL} ${READLINE} ${READLINE_DEVEL} ${NCURSES} ${NCURSES_DEVEL} ${TCL} ${TCL_DEVEL} ${SQLITE} ${SQLITE_DEVEL} ${PERL_DBI} ${PERL_DBD_SQLITE} ${PCRE_DEVEL} ${EXPAT_DEVEL} ${APR_DEVEL} ${APR_UTIL_DEVEL} ${HTTPD_DEVEL}
 
% svn commitSending        dogtag/scripts/prepare_ca
Sending        dogtag/scripts/prepare_pki
Transmitting file data ..
Committed revision 196.
Comment 16 Ade Lee 2009-01-27 13:45:06 EST
[builder@oliver redhat]$ svn diff
Index: selinux/pki-selinux.spec
===================================================================
--- selinux/pki-selinux.spec    (revision 15401)
+++ selinux/pki-selinux.spec    (working copy)
@@ -115,7 +115,7 @@
 BuildRequires:  ant >= 1.6.2, selinux-policy-devel, m4, make, policycoreutils
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_prefix}-native-tools >= 8.0.0, perl >= 5.8.0, perl-libwww-perl >= 5.8.0, policycoreutils, libsemanage
+Requires:       policycoreutils, libsemanage
 
 
 ## This package is non-relocatable!
[builder@oliver redhat]$ svn ci -m "remove unneeded dependencie for selinux runtime"
Sending        selinux/pki-selinux.spec
Transmitting file data .
Committed revision 15404.

[builder@dhcp231-124 selinux]$ svn diff pki-selinux.spec 
Index: pki-selinux.spec
===================================================================
--- pki-selinux.spec    (revision 193)
+++ pki-selinux.spec    (working copy)
@@ -115,7 +115,7 @@
 BuildRequires:  ant >= 1.6.2, selinux-policy-devel, m4, make, policycoreutils
 
 ## Without Requires something, rpmbuild will abort!
-Requires:       %{base_prefix}-native-tools >= 1.0.0, perl >= 5.8.0, perl-libwww-perl >= 5.8.0, policycoreutils, libsemanage
+Requires:       policycoreutils, libsemanage
 
 
 ## This package is non-relocatable!
[builder@dhcp231-124 selinux]$ svn ci -m "remove unneeded dependencies for selinux"
Sending        selinux/pki-selinux.spec
Transmitting file data .
Committed revision 197.
Comment 17 Jenny Galipeau 2009-06-04 14:52:32 EDT
This is a development task and not a bug.  Can dev close?
Comment 18 Ade Lee 2009-06-05 11:59:41 EDT
Closing as CURRENTRELEASE ..

Note You need to log in before you can comment on or make changes to this bug.