Bug 4807 - rpcgen generates inconsistent code
rpcgen generates inconsistent code
Status: CLOSED DUPLICATE of bug 4806
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-31 13:16 EDT by ftaylor
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 13:57:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ftaylor 1999-08-31 13:16:42 EDT
the header file generated with:

rpcgen -C -M -N -h cc.x -o cc.h

contains function definitions that are inconsistent with

rpcgen -C -M -N -c cc.x -o cc_xdr.c

functions that take 'pointer to foo' as an argument
in the .c file are defined in the .h file as taking 'foo'
as an argument

Same stuff works well on Solaris 2.x, and has for years

I can send a sample if necessary.
Comment 1 Jeff Johnson 1999-08-31 13:56:59 EDT
Please send sample. I'm going to coalesce these two problems.
Comment 2 Jeff Johnson 1999-08-31 13:57:59 EDT
*** This bug has been marked as a duplicate of 4806 ***

Note You need to log in before you can comment on or make changes to this bug.