Bug 480717 - python-setuptools 0.6c9-1.fc9 broken
python-setuptools 0.6c9-1.fc9 broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-setuptools (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 23:03 EST by David Rees
Modified: 2009-01-21 17:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 17:40:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Rees 2009-01-19 23:03:15 EST
python-setuptools 0.6c9-1.fc9 is broken.  Specifically, /usr/bin/easy_install (and /usr/bin/easy_install-2.5) still refer to version 0.6c8 of python-setuptools.

Simply updating those files to refer to 0.6c9 as expected seems to get things working again.
Comment 1 Konstantin Ryabitsev 2009-01-21 17:40:57 EST
Looking at the contents of /usr/bin/easy_install from http://kojipkgs.fedoraproject.org/packages/python-setuptools/0.6c9/1.fc9/noarch/python-setuptools-devel-0.6c9-1.fc9.noarch.rpm:

#!/usr/bin/python
# EASY-INSTALL-ENTRY-SCRIPT: 'setuptools==0.6c9','console_scripts','easy_install'
__requires__ = 'setuptools==0.6c9'
import sys
from pkg_resources import load_entry_point

sys.exit(
   load_entry_point('setuptools==0.6c9', 'console_scripts', 'easy_install')()
)

Unless I'm missing something, everything is correct.

Note, that /usr/bin/easy_install* is not provided by python-setuptools, but python-setuptools-devel. Perhaps these files on your system are left over from a manual installation? You can check by running:

rpm -qf /usr/bin/easy_install
Comment 2 David Rees 2009-01-21 17:55:58 EST
Damn, you're right.  I swear I checked that /usr/bin/easy_install was part of python-setuptools, but I just double checked, and it was not.  It was indeed left over from a previous install.

Changing the status to NOTABUG, since this obviously is not.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.