Bug 480761 - Generated mkinitrd broken with kernel-2.6.28.1-9.rc2.fc10.i686
Generated mkinitrd broken with kernel-2.6.28.1-9.rc2.fc10.i686
Status: CLOSED DUPLICATE of bug 480667
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 07:00 EST by Kevin R. Page
Modified: 2009-01-21 17:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 17:50:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blkid output (1.02 KB, text/plain)
2009-01-20 07:00 EST, Kevin R. Page
no flags Details
/etc/fstab (806 bytes, text/plain)
2009-01-20 07:01 EST, Kevin R. Page
no flags Details

  None (edit)
Description Kevin R. Page 2009-01-20 07:00:26 EST
Created attachment 329451 [details]
blkid output

Testing kernel-2.6.28.1-9.rc2.fc10.i686 for bug #470225 generates a broken mkinitrd. I enter my LUKS passphrase, but then booting halts with "error mounting /dev/root on /sysroot as ext3: no such file or directory".

mkinitrd-6.0.71-3.fc10.i386

Curiously, regenerating an initrd for kernel-2.6.27.9-159.fc10.i686 with this version of mkinitrd doesn't cause any problems.

scsi_mod.scan=sync in grub.conf (spotted in a similar looking bug) doesn't help. This could be a dupe, though the variation with kernel could make this a different bug?

blkid output and /etc/fstab attached.
Comment 1 Kevin R. Page 2009-01-20 07:01:36 EST
Created attachment 329452 [details]
/etc/fstab
Comment 2 Jeremy Katz 2009-01-20 09:21:22 EST
This is quite possibly the same root cause as bug 480667
Comment 3 Kevin R. Page 2009-01-21 17:50:15 EST

*** This bug has been marked as a duplicate of bug 480667 ***

Note You need to log in before you can comment on or make changes to this bug.