Bug 480773 - yum erase fails and requests posting to bugzilla
yum erase fails and requests posting to bugzilla
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 08:37 EST by Curtis Falany
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 14:43:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The yum update transaction output (69.79 KB, text/plain)
2009-01-20 12:49 EST, Curtis Falany
no flags Details
as much of the yum update error message as I could easily capture (30.15 KB, text/plain)
2009-01-20 12:50 EST, Curtis Falany
no flags Details

  None (edit)
Description Curtis Falany 2009-01-20 08:37:57 EST
After upgrading to Fedora 10, yum erase fails apparently due to to the presence of both i386 and x86-64 components


Version-Release number of selected component (if applicable):  yum-3.2.20-3.fc10.noarch


How reproducible:  on my system, just try to delete one of the i386 packages


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Install      0 Package(s)         
Update       0 Package(s)         
Remove      36 Package(s)         

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
gnome-vfs2 is needed by (installed) gnome-vfs2-smb-2.18.1-4.fc7.x86_64
Complete!
(1, [u'Please report this error in bugzilla'])



Expected results:  The i386 component is erased.


Additional info:  upgraded using the fedora 10 x86 64 bit DVD.  unable to 'yum update' until this is resolved.
Comment 1 Curtis Falany 2009-01-20 08:45:14 EST
This may be the same bug as 465517 and some others by the same reporter.
Comment 2 James Antill 2009-01-20 11:27:45 EST
Can you run:

yum list 'gnome-vfgs2*'

...and show the output? Also what is the complete list of packages it is trying to remove?
Comment 3 Curtis Falany 2009-01-20 12:33:34 EST
[root@localhost cefalany]# yum list 'gnome-vfgs2*'
Loaded plugins: refresh-packagekit
livna                                                    | 1.9 kB     00:00     
fedora                                                   | 2.8 kB     00:00     
adobe-linux-i386                                         |  951 B     00:00     
updates                                                  | 2.3 kB     00:00     
Error: No matching Packages to list
[root@localhost cefalany]#
Comment 4 James Antill 2009-01-20 12:45:39 EST
 Ok, and now without the typos:

yum list 'gnome-vfs2*'
Comment 5 Curtis Falany 2009-01-20 12:49:37 EST
Created attachment 329493 [details]
The yum update transaction output
Comment 6 Curtis Falany 2009-01-20 12:50:58 EST
Created attachment 329494 [details]
as much of the yum update error message as I could easily capture
Comment 7 Curtis Falany 2009-01-20 12:53:54 EST
[root@localhost cefalany]# yum list 'gnome-vfs2*'
Loaded plugins: refresh-packagekit
Installed Packages
gnome-vfs2.i386                                 2.24.0-3.fc10                      installed
gnome-vfs2.x86_64                               2.24.0-3.fc10                      installed
gnome-vfs2-devel.i386                           2.24.0-3.fc10                      installed
gnome-vfs2-devel.x86_64                         2.24.0-3.fc10                      installed
gnome-vfs2-smb.x86_64                           2.18.1-4.fc7                       installed
Available Packages
gnome-vfs2-monikers.x86_64                      2.15.3-5.fc9                       fedora   
gnome-vfs2-obexftp.x86_64                       0.4-8.fc10                         fedora   
gnome-vfs2-smb.x86_64                           2.24.0-3.fc10                      fedora   
[root@localhost cefalany]#
Comment 8 seth vidal 2009-01-20 13:00:31 EST
I'm confused. Your original report was about a 'yum remove' transaction. The attachments you've added are 'yum updates'.

We need to be able to recreate the conditions where you encountered the error. Can you still do that?
Comment 9 James Antill 2009-01-20 13:08:54 EST
Also what has happened to this box? You have .fc7, .fc9 and .fc10 packages installed. How did you install Fedora 10? ... where there are failures?
 What does "package-cleanup --problems" and "package-cleanup --dupes" show?
Comment 10 James Antill 2009-01-20 13:11:51 EST
 Hmm, reading again I see you just have one fc7 package, the fc9 one is from the repo. (and is fine) ... so a good guess is that something weird has happened with gnome-vfs2-smb-2.18.1-4.fc7
Comment 11 seth vidal 2009-01-20 13:13:53 EST
a few commands to run:

rpm -Va --nofiles --nomd5


and

rpm -e gnome-vfs2-smb-2.18.1-4.fc7
Comment 12 James Antill 2009-01-20 13:18:49 EST
 From the update report there is this:

  file /usr/share/gnome-2.0/ui/GNOME_WindowMenuApplet.xml from install of gnome-panel-2.24.2-1.fc10.x86_64 conflicts with file from package gnome-panel-2.18.3-1.fc7.i386

...which is an rpm error (and nothign we can fix in yum) ... but also implies you are doing most of a yum based update from Fedora 7 to Fedora 10. I'd recommend using preupgrade or set of CDs to "upgrade" to Fedora 10, that might solve all your problems.
Comment 13 Curtis Falany 2009-01-20 13:24:49 EST
Based on a web article, I used the 'upgrade' feature on the Fedora 10 DVD.  I was then trying to delete the conflicting (duplicate) i386 components.

I picked a package at random and tried to 'yum erase' it... and here I am.

Let me run through your suggestions and see where I get.
Comment 14 James Antill 2009-01-20 13:51:44 EST
 If the upgrade from DVD worked then you wouldn't be able to upgrade from where you are now to Fedora 10 GA pacakges, which is what your upgrade log shows.
 You should be able to use the upgrade option on the CD/DVD again, my guess is that it failed at some point though and will likely do so again :(.
Comment 15 James Antill 2009-03-06 14:43:29 EST
 As we said, there isn't anything we can do about the file conflicts problem. If your update is hosed there are a couple of last chance things you can try:

(the things about with package-cleanup)

rpm --force --nodeps -e <problem pkg>

yum shell with remove and update commands.

Note You need to log in before you can comment on or make changes to this bug.