Bug 480805 - libvirt default network not enabled at install time (chkconfig regression)
libvirt default network not enabled at install time (chkconfig regression)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Alpha/F11AlphaBlocker
  Show dependency treegraph
 
Reported: 2009-01-20 12:13 EST by Mark McLoughlin
Modified: 2014-03-16 23:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 13:45:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-01-20 12:13:22 EST
libvirt.spec has:

  # We want to install the default network for initial RPM installs
  # or on the first upgrade from a non-network aware libvirt only.
  # We check this by looking to see if the daemon is already installed
  /sbin/chkconfig --list libvirtd 1>/dev/null 2>&1
  if [ $? != 0 ]
  then
    UUID=`/usr/bin/uuidgen`
    sed -e "s,</name>,</name>\n  <uuid>$UUID</uuid>," \
         < /usr/share/libvirt/networks/default.xml \
         > /etc/libvirt/qemu/networks/default.xml
    ln -s ../default.xml /etc/libvirt/qemu/networks/autostart/default.xml
  fi
  /sbin/chkconfig --add libvirtd


This worked on F-10 and before because chkconfig would return non-zero if this is the first time libvirt is installed because 'chkconfig --add libvirtd' has not been run yet

i.e. before --add, F-10 chkconfig gives:

  $> chkconfig --list libvirtd
  service libvirtd supports chkconfig, but is not referenced in any runlevel (run 'chkconfig --add libvirtd')
  $> echo $?
  1

however, on F-11 chkconfig gives:

  $> chkconfig --list libvirtd
  libvirtd       	0:off	1:off	2:off	3:off	4:off	5:off	6:off
  $> echo $?
  0

Upshot is - if you install current rawhide, there is no libvirt default network and no external network connectivity for guests by default.
Comment 1 Mark McLoughlin 2009-01-20 12:15:15 EST
Moving to chkconfig.

notting: chkconfig behaviour change in F11 causing serious regression for libvirt

Note You need to log in before you can comment on or make changes to this bug.