This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 480820 - Cannot install systemtap
Cannot install systemtap
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemtap (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Frank Ch. Eigler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 13:11 EST by Andrig Miller
Modified: 2009-10-31 15:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-31 15:15:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrig Miller 2009-01-20 13:11:22 EST
Description of problem:

I cannot install systemtap, because it fails the dependency resolution.

Version-Release number of selected component (if applicable):

0.8-1.fc10

How reproducible:

Every time.

Steps to Reproduce:
1. Start Add/Remove Software
2. Select systemtap
3. Error on resolution
  
Actual results:

Get the following error message:

elfutils-libelf-x86_64 = 0.137-3.fc10 is needed by package elfutils-libs-0.137-3.fc10.x86_64 (fedora)


Expected results:

The package requires version 0.137-3.fc10 of elfutils-libelf, but that package is already at version 0.138-1.fc10 in the repositories, and I have that installed already.

I would think that systemtap needs to be upgraded and tested with elfutils-libelf 0.138-1.fc10, and the package updated appropriately.

Additional info:
Comment 1 Mark Wielaard 2009-01-20 13:40:59 EST
It looks like you somehow got elfutils-libelf 0.138-1.fc10 installed, which conflict with elfutils-libs-0.137-3.fc10. I don't see 0.138 in the archives, it looks like that update got pulled [*]. If so, then somehow you got a partial update of the elfutils packages installed. I don't know how that can have happened.

What does "rpm -q elfutils-libelf elfutils-libs" say?

https://admin.fedoraproject.org/updates/F10/FEDORA-2009-0151
Comment 2 William Cohen 2009-01-20 15:29:30 EST
Were only the i386 versions of elfutils*0.138-1.fc10 rpm installed? I have seen similar behavior with other multilibs yum updates and that would explain the behavior. Only the i386 version got updated and needed to explicitly force the updates for the x86_64 versions of the packages.

During the rpmbuild process dependencies on shared libraries are generated. 
SystemTap is not too picky about the version of elfutils shared libraries installed, but the dependences do include the architecture and library version. Systemtap should work with either the 0.137 and 0.138 version of the elfutil shared libraries. Putting extra explicit requires is not going to solve the problem encountered here.
Comment 3 Andrig Miller 2009-01-22 15:37:12 EST
Here's what the output of the command you asked about is:

elfutils-libelf-0.138-1.fc10.x86_64
package elfutils-libs is not installed
Comment 4 Frank Ch. Eigler 2009-09-23 11:14:59 EDT
Please check whether this problem still exists
with the more recent f10 (or f11+) builds of
systemtap / elfutils.

The dependencies you list are automatically
generated by the rpmbuild machinery, so it is
unlikely that systemtap.spec could/should be
changed to override it.  That means that if a
problem still exists, it may need to be recast
as an rpmbuild and/or elfutils problem.
Comment 5 Andrig T Miller 2009-10-31 14:51:46 EDT
I no longer have this problem, and I'm running Fedora 11 now.  This can be closed.
Comment 6 Mark Wielaard 2009-10-31 15:15:31 EDT
Resolved with the current releases of systemtap and elfutils as pointed out in comment #5

Note You need to log in before you can comment on or make changes to this bug.