Bug 480827 - [RHEL4.8][Kernel] System fails to boot with a qla2300 adapter
[RHEL4.8][Kernel] System fails to boot with a qla2300 adapter
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
All Linux
high Severity high
: rc
: ---
Assigned To: Marcus Barrow
Mike Gahagan
http://rhts.redhat.com/cgi-bin/rhts/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 13:49 EST by Jeff Burke
Modified: 2009-04-09 09:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 09:37:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2009-01-20 13:49:05 EST
Description of problem:
 While running the kernel tests. System ibm-js20-02.lab.bos.redhat.com failed to boot the updated kernel. 2.6.9-78.29.EL

Version-Release number of selected component (if applicable):
 2.6.9-78.29.EL

How reproducible:
 Always

Steps to Reproduce:
1. Reserve ibm-js20-02.lab.bos.redhat.com from RHTS
2. Install the 2.6.9-78.29.EL kernel
3. Reboot
  
Actual results:

Checking filesystems
Checking all file systems.
[/sbin/fsck.ext3 (1) -- /boot] fsck.ext3 -a /dev/md0 
/dev/md0: clean, 29/32128 files, 25959/128384 blocks
[  OK  ]
Mounting local filesystems:  [  OK  ]
Enabling local filesystem quotas:  [  OK  ]
Enabling swap space:  [  OK  ]
INIT: Entering runlevel: 3
Entering non-interactive startup
Starting monitoring for VG PPCVolGroup00: [  OK  ]
Checking for new hardware [  OK  ]
Starting pcmcia:  [  OK  ]
Setting network parameters:  [  OK  ]
Bringing up loopback interface:  [  OK  ]
Bringing up interface eth1:  [  OK  ]
Starting system logger: [  OK  ]
Starting kernel logger: [  OK  ]
Starting portmap: [  OK  ]
Starting NFS statd: [  OK  ]
Starting mdmonitor: [  OK  ]
Starting RPC idmapd: [  OK  ]
Starting iprinit: Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0,  type 12
Attached scsi generic sg1 at scsi0, channel 0, id 0, lun 1,  type 0
Attached scsi generic sg2 at scsi0, channel 0, id 1, lun 0,  type 12
Attached scsi generic sg3 at scsi0, channel 0, id 1, lun 1,  type 0

Expected results:
This should boot properly

Additional info:

The problem start with 2.6.9-78.29. The 2.6.9-78.28 works properly.

Changelog:
 * Wed Jan 14 2009 Vivek Goyal <vgoyal@redhat.com> [2.6.9-78.29]
 -qla4xxx: correct version number to 5.01.03.00.04.08-d (Marcus Barrow) [479862]
 -fix exit_itimers vs posix_timer_event ab-ba deadlock (Oleg Nesterov) [472864]
 -qla2xxx: firmware update to 4.06.01 for 8GB/s adapters (Marcus Barrow) [454839]
 -qla2xxx: firmware update to version 4.06.01 for 4GB/s adapters (Marcus Barrow) [454839]
 -qla2xxx: update to version 8.02.09.00.04.08-d (Marcus Barrow) [479094]
 -fix perfctr watchdog build warning (Aristeu Rozanski) [460920]
 -qla4xxx: code cleanups and removed dead code (Marcus Barrow) [477280]
 -qla4xxx: fix a driver timeout problem (Marcus Barrow) [477280]
 -qla4xxx: initialization fixes (Marcus Barrow) [477280]
 -qla4xxx: fixed hang during driver unload (Marcus Barrow) [477280]
 -qla4xxx: error recovery fixes (Marcus Barrow) [477280]
 -qla4xxx: dynamic ddb changes (Marcus Barrow) [477280]
 -e1000e: update to upstream version 0.3.3.3-k6 (Andy Gospodarek) [452287]
 -tsc: correct computed offset in mark_offset_tsc_hpet (Brian Maly) [451827]
 -dm snapshot: fix primary_pe race (Mikulas Patocka) [476461]
 -qla2xxx: more fix flash for isp25xx and scheduling (Marcus Barrow) [476704]
 -qla2xxx: correct flash write protect handling (Marcus Barrow) [476704]
 -qla2xxx: fix flash for isp25xx and sst flash (Marcus Barrow) [476704]
 -aio: fix race in aio_complete that leads to a process hang (Jeff Moyer)  [456686]
 -autofs4: correct offset mount expire check (Ian Kent) [475715]
 -autofs4: cleanup autofs mount type usage (Ian Kent) [475715]
 -fix rmmod ohci_hcd (Pete Zaitcev) [455843 471560]
 -sctp: fix sctp premature recieve queue backup (Neil Horman) [467273]
 -acpi: fix empty proc acpi dsdt on hp ia64 systems (Prarit Bhargava) [455253]
 -power6: secondary cpu startup delay fix (Brad Peters) [439258]
Comment 1 Marcus Barrow 2009-01-21 23:28:44 EST
I will work with Jeff Burke to get access to the logs and or system having this issue tomorrow. 

I did install the 2.6.9-79 kernel on my x86_64 system and have not been having any trouble with it. I have performed several terabytes of I/O without any errors.

If the problem is related to only booting from SAN, I don't know yet if that is the case, then I will need some help because I don't know much about those types of issues. It could have to do with order of loading modules or module configurations of some type...
Comment 3 Jeff Burke 2009-04-09 09:37:01 EDT
I have gone back and retested this with RHEL4-U8-re20090408.0 the kernel version is 2.6.9-87.EL. it appears to be fixed.

http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=53973

Note You need to log in before you can comment on or make changes to this bug.