Bug 480834 - keyjnote got renamed to impressive
keyjnote got renamed to impressive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: keyjnote (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Allisson Azevedo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 14:56 EST by Michal Jaegermann
Modified: 2009-10-05 08:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 08:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-01-20 14:56:39 EST
Description of problem:

As the subject says.  URL http://keyjnote.sourceforge.net/, displayed by package info, does not exist anymore but http://impressive.sourceforge.net/ is there.
Impressive-0.10.2 from 2008-09-18 apparently kept a version number from the last keyjnote but file sizes are not the same.

Version-Release number of selected component (if applicable):
keyjnote-0.10.2-2.fc10
keyjnote-0.10.2-1.fc9

Additional info:
I think that a transition could be handled with an appropriate use of obsoletes/provides
Comment 1 Allisson Azevedo 2009-01-25 02:21:11 EST
New Package CVS Request
=======================
Package Name: impressive
Short Description: A program that displays presentation slides.
Owners: allisson@gmail.com
Branches: F-9 F-10
Comment 2 Kevin Fenzi 2009-01-28 01:02:21 EST
FESCO is going to be discussing how to do package renames this friday... 
if you can wait for that, we should hopefully know a procedure by then.
Comment 3 Allisson Azevedo 2009-01-28 07:27:49 EST
Hi Kevin,

I agree, i'll wait for FESCO decision.
Comment 4 Kevin Fenzi 2009-02-01 13:31:14 EST
Sadly, FESCo didn't get to this discussion this last meeting. ;( 
However it should be in the next meeting. 

Sorry for the delay.
Comment 5 Kevin Fenzi 2009-02-06 12:55:42 EST
ok, FESCo talked about re-names today. 
There is still more discussion, but until then the decision is that a rename requires a new package review. Please open a new review under the new name.
Comment 6 Allisson Azevedo 2009-02-06 13:10:54 EST
Hi Kevin,

Ok, i'll submit new review-request.

Thanks!
Comment 7 Michal Jaegermann 2009-02-17 20:53:33 EST
impressive-0.10.2-3.fc9 and impressive-0.10.2-3.fc10 did show up in update repositories but it is missing in specs "Obsoletes: keyjnote".  As a result it is neither noticed as an update if keyjnote was installed nor it replaces that package if it was installed anyway.
Comment 8 Michal Jaegermann 2009-02-17 21:00:18 EST
Oops! On the top of the above impressive-0.10.2-3.fc10 want to see dejavu-fonts-sans package in dependencies but this is not available.  Curiously enough impressive-0.10.2-3.fc9 is happy with dejavu-fonts and installs fine.
Comment 9 Allisson Azevedo 2009-02-18 20:53:40 EST
The new update should fix this issues:

https://admin.fedoraproject.org/updates/F10/FEDORA-2009-1846
Comment 10 Alex Lancaster 2009-02-19 00:32:41 EST
The "Obsoletes" didn't seem to work, I have keyjnote installed:

# rpm -q keyjnote
keyjnote-0.10.2-2.fc10.noarch

but "yum update" doesn't pull in impressive.  Nor does explicitly install it remove keyjnote:

# sudo yum install impressive

Resolving Dependencies
--> Running transaction check
---> Package impressive.noarch 0:0.10.2-5.fc10 set to be updated
--> Finished Dependency Resolution
Dependencies Resolved

=============================================================================================================================================================
 Package                               Arch                              Version                                    Repository                          Size
=============================================================================================================================================================
Installing:
 impressive                            noarch                            0.10.2-5.fc10                              updates                            138 k

Transaction Summary
=============================================================================================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)
Comment 11 Alex Lancaster 2009-02-19 00:45:26 EST
The problem appears to be that you forgot to include the Provides for "impressive", i.e.:

Provides: keyjnote = %{version}-%{release}

see:

http://fedoraproject.org/wiki/PackagingDrafts/ProvidesObsoletes

otherwise yum has no way of knowing that impressive replaces i.e. "provides" keyjnote.
Comment 12 Alex Lancaster 2009-02-19 00:51:22 EST
Actually these are now in the main naming guidelines:

http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Renaming.2Freplacing_existing_packages
Comment 13 Michal Jaegermann 2009-02-19 03:06:35 EST
Re: comment #10
> Nor does explicitly install it remove keyjnote:

Hm, at least with 0.10.2-5.fc9 package I got on an install "replacing  keyjnote.noarch 0.10.2-1.fc9" and it was replaced but update did not work
since yum had no information that 'impressive' will provide 'keyjnote'.

OTOH when none of these packages was installed then 'yum install keyjnote'
caused "Package keyjnote is obsoleted by impressive, trying to install impressive-0.10.2-5.fc9.noarch instead
Nothing to do"
and I ended up with installing nothing at all.
Comment 14 Allisson Azevedo 2009-10-05 08:54:29 EDT
fixed in impressive-0.10.2-6.

Note You need to log in before you can comment on or make changes to this bug.