Bug 480837 - Enable CONFIG_CAPI_EICON and all CONFIG_ISDN_DIVAS* in kernel
Enable CONFIG_CAPI_EICON and all CONFIG_ISDN_DIVAS* in kernel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 15:13 EST by Robert Scheck
Modified: 2009-05-25 17:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.27.24-170.2.68.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 22:22:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-01-20 15:13:12 EST
Description of problem:
There are only less active ISDN card controllers supported fine with Linux
and even less supported with HylaFax which is CAPI incompatible. Yes, there
is capi4hylafax, but that software is unmaintained for years now as well.

So in the past there was the active AVM B1 ISDN card which has worked very 
well. Unluckily this card is 5V only and can't be used in modern or at least
recent server hardware, which usually only has PCI-X (3.3V only) or PCIe
(3.3V or 12V).

The only reasonable alternative seems to be Dialogic Diva (former Eicon);
so please enable CONFIG_CAPI_EICON and all CONFIG_ISDN_DIVAS* options in the
Fedora kernel (should be CONFIG_ISDN_DIVAS, CONFIG_ISDN_DIVAS_MAINT,
CONFIG_ISDN_DIVAS_USERIDI, CONFIG_ISDN_DIVAS_DIVACAPI, CONFIG_ISDN_DIVAS_HSI,
CONFIG_ISDN_DIVAS_BRIPCI, CONFIG_ISDN_DIVAS_PRIPCI, CONFIG_ISDN_DIVAS_ANALOG)
as of my knowledge. The Dialog Diva cards are available as PCI-X and as well
as PCIe - very future oriented, AVM sales itself was stating, that they will
not provide something else except AVM B1 and if we don't like it, we simply
shall look for another product...

Chuck Ebbert has enabled AFAIK CONFIG_CAPI_EICON on Fedora 10 a few hours
ago, but not on Rawhide. And the DIVAS modules aren't built as well on a
Fedora system as it seems - at least on my x86_64 locally here. The Dialogic
Diva (former Eicon) cards are known to work on ix86 and x86_64 - for ppc and
so on I can't tell you that for sure.

Version-Release number of selected component (if applicable):
kernel-2.6.27.9-159.fc10.x86_64
Comment 1 Chuck Ebbert 2009-05-20 21:59:38 EDT
This is now in Fedora 11 but somehow still not in the current F10 kernel.
Comment 2 Chuck Ebbert 2009-05-20 22:22:57 EDT
Now in F10, F11 and rawhide (F12)

I'll just close this bug now.
Comment 3 Fedora Update System 2009-05-22 05:02:14 EDT
kernel-2.6.27.24-170.2.68.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kernel-2.6.27.24-170.2.68.fc10
Comment 4 Fedora Update System 2009-05-25 17:09:43 EDT
kernel-2.6.27.24-170.2.68.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.