Bug 480929 - pvmmu?: kvm: rawhide/x86_64 guest F-10/x86_64 host - BUG: unable to handle kernel paging request at ffffc753f000f008
pvmmu?: kvm: rawhide/x86_64 guest F-10/x86_64 host - BUG: unable to handle ke...
Status: CLOSED DUPLICATE of bug 480822
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 07:52 EST by James Laska
Modified: 2013-09-02 02:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 18:03:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-01-21 07:52:31 EST
Description of problem:

While installing a rawhide/x86_64 kvm guest on a F-10/x86_64 host, my guest exhibits a call trace while starting the installer.

Version-Release number of selected component (if applicable):

 * libvirt-0.5.1-2.fc10.x86_64
 * kernel-2.6.27.9-159.fc10.x86_64
 * kvm-74-10.fc10.x86_64

How reproducible:


Steps to Reproduce:
1. Install F-10/x86_64
2. Run yum-update to get latest updates (at least libvirt-0.5.1-2.fc10.x86_64, kernel-2.6.27.9-159.fc10.x86_64)
3. Create a 1G KVM guest and install rawhide/x86_64 (see "Additional Info" for
more details on guest configuration)
  
Actual results:

      BUG: unable to handle kernel paging request at ffffc753f000f008
      IP: [<ffffffff810be806>] copy_page_range+0x311/0x7b5
      PGD 0
      Oops: 0000 [#1] SMP DEBUG_PAGEALLOC
      last sysfs file: /sys/class/firmware/timeout
      CPU 0
      Modules linked in: jfs(+) reiserfs gfs2 msdos linear raid10 raid456 async_xor async_memcpy async_tx xor raid1 raid0 8139cp 8139too mii iscsi_ibft iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ext2 ext4 jbd2 crc16 squashfs pcspkr edd floppy nfs lockd nfs_acl auth_rpcgss sunrpc vfat fat cramfs
      Pid: 674, comm: udevd Not tainted 2.6.29-0.43.rc2.git1.fc11.x86_64 #1
      RIP: 0010:[<ffffffff810be806>] [<ffffffff810be806>] copy_page_range+0x311/0x7b5
      RSP: 0018:ffff880038267c40 EFLAGS: 00010246
      RAX: ffffc753f000f008 RBX: 000000003824a000 RCX: 0000000000313000
      RDX: 0000000000000000 RSI: ffff880000000000 RDI: 000000003824b067
      RBP: ffff880038267d50 R08: ffff88003872ab70 R09: ffffffff810ba7db
      R10: ffff8800382627c0 R11: 0000000000000001 R12: ffff880038215940
      R13: 0000000000312000 R14: ffff8800382627c0 R15: ffff88003e6ab328
      FS: 00007ffadf3e3790(0000) GS:ffffffff81934000(0000) knlGS:0000000000000000
      CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
      CR2: ffffc753f000f008 CR3: 00000000381e8000 CR4: 00000000000006e0
      DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
      DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
      Process udevd (pid: 674, threadinfo ffff880038266000, task ffff88003872a350)
      Stack:
      ffff880038267c90 0000000000312fff ffff8800382627c0 ffff880038210540
      ffff880038215940 ffff8800381e8000 ffff88002dcae000 0000000000313000
      0000000000313000 ffff88003824a008 ffffc753f000f008 ffffffff810484fc
      Call Trace:
      [<ffffffff810484fc>] ? dup_mm+0x28e/0x3cc
      [<ffffffff8106ba34>] ? lock_release_holdtime+0x2c/0x123
      [<ffffffff81048538>] dup_mm+0x2ca/0x3cc
      [<ffffffff810491ec>] copy_process+0xb76/0x135c
      [<ffffffff8106ba34>] ? lock_release_holdtime+0x2c/0x123
      [<ffffffff81383cf5>] ? _spin_unlock_irqrestore+0x47/0x57
      [<ffffffff81049b32>] do_fork+0x160/0x31f
      [<ffffffff810e948e>] ? putname+0x30/0x39
      [<ffffffff81042c74>] ? default_wake_function+0x0/0xf
      [<ffffffff8101130a>] ? sysret_check+0x46/0x81
      [<ffffffff8100f62d>] sys_clone+0x23/0x25
      [<ffffffff810117c3>] stub_clone+0x13/0x20
      [<ffffffff810112ba>] ? system_call_fastpath+0x16/0x1b

      ┌──────┤ Would you like to use VNC? ├───────┐
      │                                           │
      │ The VNC mode installation offers more     │
      │ functionality than the text mode, would   │
      │ you like to use it instead?               │
      │                                           │
      │ ┌───────────────┐ ┌───────────┐           │
      │ │ Use text mode │ │ Start VNC │           │
      │ └───────────────┘ └───────────┘           │
      │                                           │
      │                                           │
      └───────────────────────────────────────────┘
      <Tab>/<Alt-Tab> between elements | <Space> selects | <F12> next screen

Expected results:

 * No kernel call trace


Additional info:

 * Installign F-10 guests does not exhibit this same call trace

 * My host is configured as follows
    # virsh nodeinfo
    CPU model:           x86_64
    CPU(s):              8
    CPU frequency:       2000 MHz
    CPU socket(s):       2
    Core(s) per socket:  4
    Thread(s) per core:  1
    NUMA cell(s):        1
    Memory size:         9229676 kB

 * My guest is configured as follows
    # virsh dominfo vguest1
    Id:             5
    Name:           vguest1
    UUID:           5ff59e32-d4c5-48ad-17e9-2898dd0df18f
    OS Type:        hvm
    State:          running
    CPU(s):         1
    CPU time:       646.7s
    Max memory:     1048576 kB
    Used memory:    1048576 kB
    Autostart:      disable
Comment 1 Marcelo Tosatti 2009-02-27 15:57:04 EST
This looks like another instance of the pvmmu bug. I'll make sure the fix is applied to FC10, and then we can confirm the bug is closed.
Comment 2 Marcelo Tosatti 2009-03-04 10:55:34 EST
James,

kernel-2.6.27.19-170.2.35.fc10 contains a fix for the pvmmu bug. Can you confirm 
whether it fixes the issue?

Thanks
Comment 3 Marcelo Tosatti 2009-03-04 10:58:31 EST
Err, the guest is FC11. So you should try a build with kernel > 2.6.29-rc5.
Comment 4 Marcelo Tosatti 2009-03-04 18:03:02 EST
Thanks James.
Comment 5 Mark McLoughlin 2009-03-25 13:55:47 EDT
Marking as a dup of the original pvmmu bug

*** This bug has been marked as a duplicate of bug 480822 ***

Note You need to log in before you can comment on or make changes to this bug.