Bug 480958 - tomboy crashes on start up
Summary: tomboy crashes on start up
Status: CLOSED DUPLICATE of bug 465149
Alias: None
Product: Fedora
Classification: Fedora
Component: tomboy   
(Show other bugs)
Version: 10
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-21 15:09 UTC by Tom Cross
Modified: 2009-02-17 18:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 18:26:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Cross 2009-01-21 15:09:59 UTC
Description of problem:
Trying to add tomboy to my panel -- or start it on the command line.  Neither work, both crash.

Version-Release number of selected component (if applicable):
tomboy-0.12.0-5.fc10.x86_64


How reproducible:
everytime

Steps to Reproduce:
1. commandline:  "tomboy"
2.
3.
  
Actual results:
$ tomboy
[DEBUG]: NoteManager created with note path "/home/users/tomc/.tomboy".

** (Tomboy:4816): WARNING **: The following assembly referenced from /usr/lib64/tomboy/Tomboy.exe could not be loaded:
     Assembly:   Mono.Addins    (assemblyref_index=8)
     Version:    0.3.0.0
     Public Key: 0738eb9f132ed756
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/lib64/tomboy).


** (Tomboy:4816): WARNING **: Could not load file or assembly 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.

** (Tomboy:4816): WARNING **: Missing method .ctor in assembly /usr/lib64/tomboy/Tomboy.exe, type Mono.Addins.AddinEventHandler

** (Tomboy:4816): WARNING **: Missing method .ctor in assembly /usr/lib64/tomboy/Tomboy.exe, type Mono.Addins.AddinEventHandler

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.
File name: 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'
  at Tomboy.AddinManager..ctor (System.String tomboy_conf_dir) [0x00000] 
  at Tomboy.NoteManager.CreateAddinManager () [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory, System.String backup_directory) [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory) [0x00000] 
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000] 


Additional info:

Fresh install of f10 with all current updates.  My homedir is NFS mounted and I've been using tomboy since it was first included in Fedora.  My homedir is *not* fresh/new, but my f10 install is.

Comment 1 Tom Cross 2009-01-22 16:20:03 UTC
I tried "mv .tomboy .tomboy-backup" just to see if there was some corrupt data in there that would goof it up.  It didn't help.

Is there some way to turn on debuging to see what the problem is?

Thanks

Comment 2 Austin Acton 2009-02-01 16:50:23 UTC
Same problem here, but using:
- i386
- clean /home
- ext3 filesystem under LVM

Comment 3 Austin Acton 2009-02-01 16:54:40 UTC
This is a duplicate of <a href="https://bugzilla.redhat.com/show_bug.cgi?id=465149">bug 465149</a>.

Comment 4 Jon Dufresne 2009-02-17 18:26:47 UTC

*** This bug has been marked as a duplicate of bug 465149 ***


Note You need to log in before you can comment on or make changes to this bug.