Bug 481017 - Dead keys not working in QT applications
Dead keys not working in QT applications
Status: CLOSED DUPLICATE of bug 468590
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 13:34 EST by Davide Cescato
Modified: 2009-01-21 13:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 13:58:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Davide Cescato 2009-01-21 13:34:07 EST
Description of problem:

Under QT applications (e.g., scribus, qt4-config), dead keys do not work as expected. Instead of merging the accent and the letter to be accented into a single character, accent and letter are kept separated and form a two-character sequence.

The bug does not arise in GTK applications (e.g., gedit, gnome-terminal).


Version-Release number of selected component (if applicable):

I have a F10 x86_64 system, installed from a live image, with all updates (as of 2009-01-21) installed. Except for the Adobe flash player plugin and skype, the system does not contain any third-party packages.

I use the Swiss French keyboard layout.

Here some info about my system configuration:
[raw@f10sys ~]$ rpmquery --all |grep qt
qt-4.4.3-10.fc10.i386
qt-4.4.3-10.fc10.x86_64
qt-x11-4.4.3-10.fc10.x86_64
qt-x11-4.4.3-10.fc10.i386
[raw@f10sys ~]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
[raw@f10sys ~]$ xprop -root |grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "ch", "fr", ""
_XKB_RULES_NAMES(STRING) = "evdev", "pc105", "ch", "fr", "altwin:super_win"


How reproducible:

On my Fedora 10 system, the bug is always reproducible.


Steps to Reproduce:

1. run gnome-keyboard-properties
2. under the "Layouts" tab, select keyboard model "Generic 105-key (Intl) PC" and layout "Switzerland French"
3. run qtconfig-qt4
4. under the "Fonts" tab, place the text cursor inside the "Sample Text" text field, so that input from the keyboard will be directed to that text field 
5. push the '^' key, then push the 'u' key
(in the Swiss French layout, the '^' key is the second key to the right of the '0' key)
  

Actual results:

The two characters '^u' are displayed in the text field.


Expected results:

The character 'รป' is displayed in the text field.


Additional info:

The bug does not affect my F9 x86_64 system that I have installed on a different partition of the same machine. There I have the following configuration:
[ceski@f9sys ~]$ rpmquery --all |grep qt
qt-x11-4.4.3-10.fc9.x86_64
qt-4.4.3-10.fc9.i386
qt3-3.3.8b-14.fc9.x86_64
qt-4.4.3-10.fc9.x86_64
qt-x11-4.4.3-10.fc9.i386
[ceski@f9sys ~]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
[ceski@f9sys ~]$ xprop -root |grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "ch", "fr", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "ch", "fr", "altwin:super_win"
Comment 1 Kevin Kofler 2009-01-21 13:58:42 EST

*** This bug has been marked as a duplicate of bug 468590 ***

Note You need to log in before you can comment on or make changes to this bug.