Bug 481027 - backport the fix to the misordered write bug in dm-exception-store.c to the next RHEL4/RHEL5 updates
backport the fix to the misordered write bug in dm-exception-store.c to the n...
Status: CLOSED DUPLICATE of bug 496102
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 14:43 EST by luping.nju
Modified: 2010-06-23 11:23 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 11:23:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description luping.nju 2009-01-21 14:43:34 EST
Description of problem:

In dm-exception-store.c, when a metatdata chunk is filled in, the code firstly write to disk the current metadata chunk and then zero out the next metadata chunk. This could end up with a inconsistent exception data structure on disk if there is a power outage / kernel crash coming in between the two writes.

The bug has actually been fixed in the current mainstream kernel by Mikulas Patocka. See the following link:

http://lkml.indiana.edu/hypermail/linux/kernel/0810.3/0020.html

But I am not sure if it's going to be in the next RHEL4/RHEL5 updates. So here I am requesting to have this included in the next updates.

Version-Release number of selected component (if applicable):

It exists on all the stable RHEL4/RHEL5 releases

How reproducible:

It's hard to reproduce in real life, but we can certainly simulate this by manually put a "die" in between the two writes.

Additional info:
Comment 2 Milan Broz 2010-06-23 11:23:37 EDT

*** This bug has been marked as a duplicate of bug 496102 ***

Note You need to log in before you can comment on or make changes to this bug.