Bug 481029 - gnome-panel-2.25.5-1.fc11.x86_64.rpm fails to start: no panel, just desktop background
gnome-panel-2.25.5-1.fc11.x86_64.rpm fails to start: no panel, just desktop b...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 15:09 EST by Tom London
Modified: 2009-01-23 12:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-23 11:12:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
~/.xsession-errors.old (actually the .xsession-errors file from the failing session) (22.03 KB, text/plain)
2009-01-21 15:09 EST, Tom London
no flags Details
~/.xsession-errors.old showing >200 gnome-panel ERRORS (37.31 KB, text/plain)
2009-01-23 09:44 EST, Tom London
no flags Details
/var/log/Xorg.0.log from session with failing gnome-panel (271.59 KB, text/plain)
2009-01-23 09:50 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2009-01-21 15:09:42 EST
Created attachment 329648 [details]
~/.xsession-errors.old (actually the .xsession-errors file from the failing session)

Description of problem:
If I install gnome-panel-2.25.5-1.fc11.x86_64.rpm and logoff/login (or reboot), gnome appears to start up, but I get no top or bottom panel, and no apps, etc.

Reverting to gives me working panels.

I attach ~/.xsession-errors from the failing session.

Here are the packages installed when I have working panels:
gnome-audio-2.22.2-2.fc10.noarch
gnome-python2-libegg-2.19.1-28.fc11.x86_64
gnome-keyring-pam-2.25.5-1.fc11.x86_64
gnome-python2-gnomekeyring-2.25.1-1.fc11.x86_64
gnome-panel-2.25.3-5.fc11.x86_64
gnome-mag-0.15.4-4.fc11.x86_64
gnome-keyring-devel-2.25.5-1.fc11.x86_64
gnome-terminal-2.25.5-1.fc11.x86_64
gnome-speech-0.4.22-1.fc10.x86_64
gnome-screensaver-2.25.2-2.fc11.x86_64
gnome-bluetooth-0.11.0-8.fc11.x86_64
gnome-python2-gnome-2.25.1-1.fc11.x86_64
gnome-python2-canvas-2.25.1-1.fc11.x86_64
gnome-themes-2.25.5-1.fc11.noarch
gnome-packagekit-0.4.0-2.fc11.x86_64
gnome-menus-2.25.5-1.fc11.x86_64
gnome-python2-libwnck-2.25.1-1.fc11.x86_64
gnome-python2-bonobo-2.25.1-1.fc11.x86_64
gnome-games-2.25.4-1.fc11.x86_64
gnome-applet-music-2.5.0-1.fc11.x86_64
gnome-power-manager-2.25.2-1.fc11.x86_64
gnome-keyring-debuginfo-2.25.4.2-1.fc11.x86_64
gnome-applets-2.25.3-3.fc11.x86_64
gnome-mime-data-2.18.0-3.fc10.noarch
gnome-icon-theme-2.24.0-1.fc10.noarch
gnome-mount-0.8-1.fc9.x86_64
gnome-python2-gtkhtml2-2.19.1-28.fc11.x86_64
gnome-pilot-2.0.17-1.fc11.x86_64
gnome-vfs2-devel-2.24.0-4.fc11.x86_64
gnome-keyring-2.25.5-1.fc11.x86_64
gnome-desktop-2.25.5-1.fc11.x86_64
gnome-python2-applet-2.25.1-1.fc11.x86_64
gnome-python2-gnomevfs-2.25.1-1.fc11.x86_64
gnome-panel-libs-2.25.3-3.fc11.x86_64
gnome-desktop-sharp-2.24.0-3.fc10.x86_64
gnome-backgrounds-2.24.0-3.fc10.noarch
gnome-bluetooth-libs-0.11.0-8.fc11.x86_64
gnome-doc-utils-stylesheets-0.14.2-1.fc11.noarch
gnome-media-2.25.1-5.fc11.x86_64
gnome-session-2.25.3-1.fc11.x86_64
gnome-python2-2.25.1-1.fc11.x86_64
gnome-python2-desktop-2.25.1-1.fc11.x86_64
gnome-user-share-0.41-1.fc11.x86_64
gnome-utils-2.25.2-1.fc11.x86_64
gnome-settings-daemon-2.25.3-4.fc11.x86_64
gnome-vfs2-2.24.0-4.fc11.x86_64
gnome-python2-gconf-2.25.1-1.fc11.x86_64
gnome-system-monitor-2.24.4-1.fc11.x86_64
gnome-sharp-2.24.0-1.fc10.x86_64
gnome-python2-extras-2.19.1-28.fc11.x86_64
gnome-media-libs-2.25.1-5.fc11.x86_64
gnome-python2-gnomeprint-2.25.1-1.fc11.x86_64
gnome-session-xsession-2.25.3-1.fc11.x86_64



Version-Release number of selected component (if applicable):
gnome-panel-2.25.5-1.fc11.x86_64.rpm

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-01-21 15:10:53 EST
Here are issues from ~/.xsession-errors:

ERROR:applet.c:969:panel_applet_load_idle_handler: code should not be reached
**
ERROR:applet.c:969:panel_applet_load_idle_handler: code should not be reached
Comment 2 Tom London 2009-01-22 09:57:19 EST
Reverting just gnome-panel* and gnome-session* packages "fixes for me"
Comment 3 Tom London 2009-01-23 09:44:21 EST
Created attachment 329838 [details]
~/.xsession-errors.old showing >200 gnome-panel ERRORS

I tried again with today's rawhide (listed below).

gnome-panel still "busted", but this time it seemed to try to restart gnome-panel repetitively.

~/.xsession-errors attached, showing gnome-panel trying really, really hard to start.  Got the following message over 200 times before I killed it (via alt-ctrl-F2, telinit 3).

I again reverted gnome-panel* and gnome-session* to "make it work".

Is there some way I can debug/test and/or provide more data/info?

Jan 23 06:19:45 Updated: gnome-panel-libs-2.25.5-1.fc11.x86_64
Jan 23 06:19:51 Updated: 1:qt-4.4.3-12.fc11.x86_64
Jan 23 06:19:52 Updated: apr-util-1.3.4-2.fc11.x86_64
Jan 23 06:19:52 Updated: apr-util-ldap-1.3.4-2.fc11.x86_64
Jan 23 06:20:02 Updated: 1:qt-x11-4.4.3-12.fc11.x86_64
Jan 23 06:20:06 Updated: qt3-3.3.8b-18.fc11.x86_64
Jan 23 06:20:11 Updated: policycoreutils-2.0.61-6.fc11.x86_64
Jan 23 06:20:13 Updated: mysql-libs-5.1.30-2.fc11.x86_64
Jan 23 06:20:14 Updated: redland-1.0.7-5.fc11.x86_64
Jan 23 06:20:15 Updated: libedit-2.11-2.20080712cvs.fc11.x86_64
Jan 23 06:20:16 Updated: jwhois-4.0-9.fc11.x86_64
Jan 23 06:20:40 Updated: policycoreutils-python-2.0.61-6.fc11.x86_64
Jan 23 06:20:41 Updated: 1:control-center-filesystem-2.25.3-5.fc11.x86_64
Jan 23 06:21:21 Updated: 1:control-center-2.25.3-5.fc11.x86_64
Jan 23 06:21:41 Updated: gnome-session-2.25.5-2.fc11.x86_64
Jan 23 06:21:41 Updated: gnome-session-xsession-2.25.5-2.fc11.x86_64
Jan 23 06:22:09 Updated: gnome-panel-2.25.5-1.fc11.x86_64
Jan 23 06:22:11 Updated: policycoreutils-gui-2.0.61-6.fc11.x86_64
Jan 23 06:22:17 Updated: tzdata-2009a-1.fc11.noarch
Jan 23 06:22:20 Updated: tzdata-java-2009a-1.fc11.noarch
Jan 23 06:22:21 Updated: PackageKit-glib-0.4.2-1.fc11.x86_64
Jan 23 06:22:43 Updated: gnome-media-libs-2.25.5-1.fc11.x86_64
Jan 23 06:22:43 Updated: PackageKit-gtk-module-0.4.2-1.fc11.x86_64
Jan 23 06:22:53 Updated: gnome-media-2.25.5-1.fc11.x86_64
Jan 23 06:22:54 Updated: PackageKit-gstreamer-plugin-0.4.2-1.fc11.x86_64
Jan 23 06:22:54 Updated: PackageKit-yum-0.4.2-1.fc11.x86_64
Jan 23 06:22:57 Installed: PackageKit-0.4.2-1.fc11.x86_64
Jan 23 06:22:57 Updated: PackageKit-yum-plugin-0.4.2-1.fc11.x86_64
Jan 23 06:23:17 Updated: gnome-packagekit-0.4.2-1.fc11.x86_64
Jan 23 06:23:29 Erased: PackageKit-udev-helper

I don't see anything "obvious" in /var/log/Xorg.0.log.  Here are the diffs between a working session and a broken one:

[root@tlondon ~]# diff /var/log/Xorg.0.log* | more
22c22
< (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 23 06:32:11 2009
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 23 06:27:46 2009
31c31
< (--) using VT number 7
---
> (++) using VT number 1
4183c4183,4204
< exaCopyDirty: Pending damage region empty!
---
> (II) AIGLX: Suspending AIGLX clients for VT switch
> (II) P.I. Engineering PC Keyboard/Mouse to USB  Adapter: Close
> (II) UnloadModule: "evdev"
> (II) Macintosh mouse button emulation: Close
> (II) UnloadModule: "evdev"
> (II) TPPS/2 IBM TrackPoint: Close
> (II) UnloadModule: "evdev"
> (II) ThinkPad Extra Buttons: Close
> (II) UnloadModule: "evdev"
> (II) AT Translated Set 2 keyboard: Close
> (II) UnloadModule: "evdev"
> (II) P.I. Engineering PC Keyboard/Mouse to USB  Adapter: Close
> (II) UnloadModule: "evdev"
> (II) Sleep Button (CM): Close
> (II) UnloadModule: "evdev"
> (II) Video Bus: Close
> (II) UnloadModule: "evdev"
> (II) Power Button (FF): Close
> (II) UnloadModule: "evdev"
> (II) intel(0): [drm] removed 1 reserved context for kernel
> (II) intel(0): [drm] unmapping 8192 bytes of SAREA 0x1efff000 at 0x7faaafe2900
0
> (II) intel(0): [drm] Closed DRM master.
[root@tlondon ~]#
Comment 4 Tom London 2009-01-23 09:50:56 EST
Created attachment 329840 [details]
/var/log/Xorg.0.log from session with failing gnome-panel

Just in case it's useful, I'm attaching Xorg.0.log from failing session.

For completeness, system is Thinkpad X200 with Intel graphics:

[root@tlondon ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
[root@tlondon ~]#
Comment 5 Tom London 2009-01-23 10:16:00 EST
OK... some googling shows this problem exists on Ubuntu too: http://ubuntuforums.org/showpost.php?s=e9c81bfc72d143c357591fe5ca44913e&p=6589048&postcount=9

The workaround described here: http://ubuntuforums.org/showpost.php?p=6589663&postcount=12  "works for me".

I did the following:

cd ~/.gconf/apps
mv panel panel.old

and then logged out and logged in again.  I got my panel back: actually got the "Fedora standard" panel back.

Could there be a problem with some panel apps?

"ls diff" of "new" ~/.gconf/apps/panel and 'old' ~/.gconf/apps/panel.old:

[tbl@tlondon apps]$ ls -l panel*/applets
panel/applets:
total 12
drwx------ 3 tbl tbl 4096 2009-01-23 07:08 clock
-rw------- 1 tbl tbl    0 2009-01-23 07:08 %gconf.xml
drwx------ 3 tbl tbl 4096 2009-01-23 07:08 window_list
drwx------ 3 tbl tbl 4096 2009-01-23 07:08 workspace_switcher

panel.old/applets:
total 40
drwx------ 3 tbl tbl 4096 2008-11-07 09:04 applet_0
drwx------ 3 tbl tbl 4096 2009-01-07 13:59 applet_1
drwx------ 3 tbl tbl 4096 2009-01-07 06:33 applet_2
drwx------ 3 tbl tbl 4096 2009-01-08 17:14 clock
-rw------- 1 tbl tbl    0 2009-01-07 07:24 %gconf.xml
drwx------ 3 tbl tbl 4096 2008-11-11 07:21 mixer
drwx------ 2 tbl tbl 4096 2009-01-08 17:14 systray
drwx------ 2 tbl tbl 4096 2009-01-08 17:14 tomboy
drwx------ 2 tbl tbl 4096 2008-10-25 10:45 trash_applet
drwx------ 3 tbl tbl 4096 2008-10-17 14:12 window_list
drwx------ 3 tbl tbl 4096 2008-10-25 10:45 workspace_switcher
[tbl@tlondon apps]$ 

I have "lost" some applets from the top panel......
Comment 6 Tom London 2009-01-23 10:25:20 EST
OK.  Think I "found something":  Trying to add back a "seperator" to the top panel recreates the offending error:

ERROR:applet.c:969:panel_applet_load_idle_handler: code should not be reached
**
ERROR:applet.c:969:panel_applet_load_idle_handler: code should not be reached
**
ERROR:applet.c:969:panel_applet_load_idle_handler: code should not be reached
**
ERROR:applet.c:969:panel_applet_load_idle_handler: code should not be reached
Comment 7 Ray Strode [halfline] 2009-01-23 10:55:33 EST
Ah thanks for the detective work.  Will reproduce and fix shortly.
Comment 8 Ray Strode [halfline] 2009-01-23 11:00:42 EST
Actually, doesn't look like I need.  Talked to Vincent:

[10:59:17] <vuntz> halfline: actually, try 2.25.5.1                
[10:59:24] <vuntz> the user most probably has a separator
[10:59:31] <halfline> vuntz: oh yea he does
[10:59:33] <vuntz> halfline: there was a missing break statement...

Will build 2.25.5.1 today.
Comment 9 Ray Strode [halfline] 2009-01-23 11:12:01 EST
It's building now.
Comment 10 Tom London 2009-01-23 12:10:02 EST
I can confirm: downloaded from koji/installed/logged out/logged in.

Adding "separator" now works.

Thanks for the quick fix!

Note You need to log in before you can comment on or make changes to this bug.