Bug 481043 - ALSA driver problem in F10
ALSA driver problem in F10
Status: CLOSED DUPLICATE of bug 497636
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 16:35 EST by alauschke
Modified: 2009-08-03 04:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 04:09:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
errors in log file (301.12 KB, image/png)
2009-01-21 16:35 EST, alauschke
no flags Details

  None (edit)
Description alauschke 2009-01-21 16:35:48 EST
Created attachment 329661 [details]
errors in log file

Description of problem:
Bug in ALSA drivers that I don't understand enough to describe in detail. I am a user and not a Linux programmer.

Observations:
- Trying the "test call" feature in Ekiga shows that although mike input is recognised, it doesn't get forwarded to Ekiga. PulseAudio still has it, Ekiga does not.
- Mike recording itself without ALSA (e. g. to harddrive) works.
- ALSA errors written to log file every three seconds or so.

A senior RedHat programmer then told me I should file this as an ALSA bug after seeing the screenshot.
  
This may be related to PulseAudio, but after a while everything pointed towards a bug in ALSA. And given that ALSA is part of kernel and there is no category "ALSA" I was recommended to file this as a kernel bug. This may also be related to a bug in the driver(s) for my soundcard (it's a laptop), but again, a senior RedHat programmer then recommended to file this as an ALSA bug.

Actual results:
See screenshot and lsmod | grep snd output

Expected results:
ALSA drivers are supposed to work.

Additional info:

lsmod | grep snd

[root@localhost ~]# lsmod | grep snd
snd_usb_audio          78596  0 
snd_usb_lib            17920  1 snd_usb_audio
snd_rawmidi            22272  1 snd_usb_lib
snd_hwdep              10372  1 snd_usb_audio
snd_atiixp_modem       15624  0 
snd_atiixp             18956  3 
snd_ac97_codec         96672  2 snd_atiixp_modem,snd_atiixp
ac97_bus                5504  1 snd_ac97_codec
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
snd_seq                48320  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          9996  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            41600  0 
snd_mixer_oss          16896  1 snd_pcm_oss
snd_pcm                64772  5 snd_usb_audio,snd_atiixp_modem,snd_atiixp,snd_ac97_codec,snd_pcm_oss
snd_timer              21896  2 snd_seq,snd_pcm
snd                    51768  21 snd_usb_audio,snd_usb_lib,snd_rawmidi,snd_hwdep,snd_atiixp_modem,snd_atiixp,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9416  1 snd
snd_page_alloc         11144  3 snd_atiixp_modem,snd_atiixp,snd_pcm
Comment 1 Lubomir Rintel 2009-08-03 04:09:00 EDT

*** This bug has been marked as a duplicate of bug 497636 ***

Note You need to log in before you can comment on or make changes to this bug.