This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 481047 - Package Updater crashes with pirut traceback
Package Updater crashes with pirut traceback
Status: CLOSED DUPLICATE of bug 491916
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
low Severity urgent
: rc
: ---
Assigned To: James Antill
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 16:54 EST by Bob Bevill
Modified: 2013-01-10 05:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 11:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Traceback (19.51 KB, text/plain)
2009-01-21 16:58 EST, Bob Bevill
no flags Details
crash after updating (2.58 KB, text/plain)
2009-09-17 16:39 EDT, Johnny Soedomo
no flags Details

  None (edit)
Description Bob Bevill 2009-01-21 16:54:28 EST
Description of problem:

When running Package Updater immediately after registering the client with RHN Satellite Server, using the new 1.0-2 certificate,  Package Updater aborts with a pirut traceback error, listing several symptoms.


Version-Release number of selected component (if applicable):
v5.2 using rhn-org-trusted-ssl-cert-1.0-2.noarch.rpm to register new clients with RHN Satellite Server v5.0

How reproducible:
Every time

Steps to Reproduce:
1. Register new client with 
2. http://<<satellite-server>>/pub/rhn-org-trusted-ssl-cert-1.0-2.noarch.rpm
3. Select Applications--> System Tools--> Package Updater
4. Register client with RHN Satellite Server.
5. Run Package Updater a second time to query for available packages.
6. pirut traceback occurs
Comment 1 Bob Bevill 2009-01-21 16:58:31 EST
Created attachment 329665 [details]
Traceback
Comment 2 Bob Bevill 2009-01-22 16:29:14 EST
If you need further information please contact me at SiCortex, customer number 1039280.

Thanks,
Bob Bevill
603-913-1770 cell
Comment 3 samuel.cable 2009-09-11 09:46:04 EDT
I am getting the same problem on two different machines.  My traceback file looks just like Bob Bevill's.  Appreciate whatever you can do.  Thanks.
Comment 4 James Antill 2009-09-17 10:51:31 EDT
SyntaxError: mismatched tag: line 39874, column 8

...does "yum clean metadata" fix the problem?

 Can you upload the repodata?
Comment 5 Bob Bevill 2009-09-17 16:14:03 EDT
I no longer work at SiCortex and not actively pursuing this bug.  Workaround was to completely rebuild RHN server with only the 1.0.2 certs installed.
Comment 6 Johnny Soedomo 2009-09-17 16:39:19 EDT
Created attachment 361563 [details]
crash after updating
Comment 7 Johnny Soedomo 2009-09-17 16:40:00 EDT
I had a similar problem but different error message. However, I did "yum clean metadata" and that resolved the issues. Thanks.
Comment 8 James Antill 2009-09-18 11:47:58 EDT
The problem from Johnny is the metadata parser thing, so closing.

Not sure how you can get corrupted XML MD, but given the fix I'm going to silently blame RHN :).

*** This bug has been marked as a duplicate of bug 491916 ***
Comment 9 samuel.cable 2009-09-23 09:25:51 EDT
"yum clean metadata" fixed the problem on our three machines.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.