Bug 481059 - Software Channels display Bug
Software Channels display Bug
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Red Hat Satellite QA List
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-01-21 17:36 EST by Brian Kosick
Modified: 2009-09-10 08:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 08:05:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Kosick 2009-01-21 17:36:45 EST
Description of problem:
When I go to Manage Software channels, and Expand/Collapse a channel
tree, the parent channel disappears from the channels list!

So something like this

Fedora 10
Redhat 5.2

Expand

Fedora 10
 - Fedora 10 32bit
 - Fedora 10 64bit
Redhat 5.2

Collapse

Redhat 5.2

If you refresh the page, it comes back just fine....

Version-Release number of selected component (if applicable):
Spacewalk WebUI 0.4

How reproducible:
Every time

Steps to Reproduce:
1. Go to Channel Management
2. Expand/Collapse a Channel
3.
  
Actual results:
The channel that you expand/collapse disappears from the UI

Expected results:
Channel should remain in UI

Additional info:
Comment 1 Travis Camechis 2009-03-05 13:50:15 EST
Can anyone verify that this is still an issue.  I was unable to reproduce with a fresh build.
Comment 2 Clifford Perry 2009-06-23 13:28:54 EDT
Going to see if we can reproduce, and if so attempt to fix for Space06.
Comment 3 Devan Goodwin 2009-07-27 12:42:33 EDT
Manage Software Channels no longer seems to allow you to collapse trees, although the main channel page does. Cannot reproduce, so moving this to verified for now.

If anyone hits this again please respond with details including browser and version.
Comment 4 Miroslav Suchý 2009-09-10 08:05:10 EDT
Spacewalk 0.6 released

Note You need to log in before you can comment on or make changes to this bug.