This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 481068 - bitmap-fonts needs updating to revised packaging guidelines
bitmap-fonts needs updating to revised packaging guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bitmap-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 225617 F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-01-21 18:29 EST by Jens Petersen
Modified: 2009-10-09 01:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 01:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-01-21 18:29:44 EST
Description of problem:
When bitmap-fonts gets installed there are a bunch of fc-cache errors appearing in rawhide.

bitmap-fonts needs to be updated to the latest packaging guidelines and macros.

Version-Release number of selected component (if applicable):
bitmap-fonts-0.3-6.fc10

How reproducible:
every time 

Steps to Reproduce:
1. spin Live
  
Actual results:
  Installing: bitmap-fonts                 ##################### [727/950]/usr/share/fonts: failed to write cache
/usr/share/fonts/VLGothic: failed to write cache
/usr/share/fonts/abyssinica: failed to write cache
/usr/share/fonts/bitmap-fonts: failed to write cache
/usr/share/fonts/cjkunifonts: failed to write cache
/usr/share/fonts/default: failed to write cache
/usr/share/fonts/default/Type1: failed to write cache
/usr/share/fonts/default/ghostscript: failed to write cache
/usr/share/fonts/dejavu: failed to write cache
/usr/share/fonts/jomolhari: failed to write cache
/usr/share/fonts/kacst: failed to write cache
/usr/share/fonts/khmeros: failed to write cache
/usr/share/fonts/lklug: failed to write cache
/usr/share/fonts/lohit-bengali: failed to write cache
/usr/share/fonts/lohit-gujarati: failed to write cache
/usr/share/fonts/lohit-hindi: failed to write cache
/usr/share/fonts/lohit-kannada: failed to write cache
/usr/share/fonts/lohit-maithili: failed to write cache
/usr/share/fonts/lohit-oriya: failed to write cache
/usr/share/fonts/lohit-punjabi: failed to write cache
/usr/share/fonts/lohit-tamil: failed to write cache
/usr/share/fonts/lohit-telugu: failed to write cache
/usr/share/fonts/mathml: failed to write cache
/usr/share/fonts/padauk: failed to write cache
/usr/share/fonts/paktype: failed to write cache
/usr/share/fonts/stix: failed to write cache
/usr/share/fonts/thaifonts-scalable: failed to write cache
/usr/share/fonts/un-core: failed to write cache
/usr/share/fonts/zh_CN: failed to write cache
/usr/share/fonts/zh_CN/TrueType: failed to write cache
/usr/share/fonts/zh_TW: failed to write cache
/usr/share/fonts/zh_TW/TrueType: failed to write cache
error: %post(bitmap-fonts-0.3-6.fc10.noarch) scriptlet failed, exit status 32

Expected results:
Should not fail with error 32

Additional info:
Actual above errors are probably due to fontconfig error, but install should not fail anyway.
Comment 1 Jens Petersen 2009-01-22 18:39:51 EST
Fontconfig got fixed but the package still needs updating to the new macros I think.
Comment 2 Jens Petersen 2009-04-07 01:54:59 EDT
This is going to miss F11 - dropping from F11Target.
Comment 3 Bug Zapper 2009-06-09 06:49:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Pravin Satpute 2009-09-11 07:38:17 EDT
ok, i will work on this next week
Comment 5 Matěj Cepl 2009-09-21 04:22:50 EDT
(In reply to comment #4)
> ok, i will work on this next week  

ping?
Comment 6 Pravin Satpute 2009-09-21 05:36:09 EDT
http://pravins.fedorapeople.org/bitmap-fonts-0.3-9.fc11.src.rpm
http://pravins.fedorapeople.org/bitmap-fonts.spec

i think it need review as it is very basic package and its merge-review is also pending

can someone review it?
Comment 7 Nicolas Mailhot 2009-09-21 05:54:54 EDT
I'll look at it this evening
Comment 8 Nicolas Mailhot 2009-09-21 17:42:02 EDT
Well fc-scan shows that most of the bdf files declare themselves as "Fixed", two of them think they are "Fangsong ti" and the others are not parsable by fc-scan.

So you need at minimum a

1. a foo-fixed-fonts subpackage, 
2. a foo-fangsong-ti-fonts subpackage, 
3. and get Behdad to look at the other files and tell you if it's a bug his side or if the files need some form of fixing. Fontconfig won't be able to use them if it can't read the font name inside. The readme says they are Lucida but fontconfig does not read readmes. 

Also
- it would be probably cleaner to package the ucs fonts in a ucs-fixed-fonts package instead of hiding their origin in a collection package
- the licensing of Fangsong ti needs to be extracted from the fonts in a .txt people can actually read.
Comment 9 Pravin Satpute 2009-09-22 01:42:43 EDT
(In reply to comment #8)
> 2. a foo-fangsong-ti-fonts subpackage, 
bitmap-cjk-fonts has only fansongti fonts file, should we change it name?
like bitmap-cjk-fangsongti-fonts

> 
> Also
> - it would be probably cleaner to package the ucs fonts in a ucs-fixed-fonts
> package instead of hiding their origin in a collection package

can you elaborate more on this, which font exactly?
Comment 10 Jens Petersen 2009-09-22 01:51:53 EDT
As I commented in the merge review (and this still needs
proper checking) but most bdf fonts already seem to be in
xorg-x11-fonts - so I am starting wonder if this package
could just be dropped become fangsongti-fonts?
Comment 11 Nicolas Mailhot 2009-09-22 01:55:34 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > 2. a foo-fangsong-ti-fonts subpackage, 
> bitmap-cjk-fonts has only fansongti fonts file, should we change it name?
> like bitmap-cjk-fangsongti-fonts

I'd not mention the cjk bit at all

> > Also
> > - it would be probably cleaner to package the ucs fonts in a ucs-fixed-fonts
> > package instead of hiding their origin in a collection package
> 
> can you elaborate more on this, which font exactly?  

The readme says fixed is a copy of 
http://www.cl.cam.ac.uk/~mgk25/ucs-fonts.html

If we packaged it today it'd end up in a ucs-fonts or 
ucs-fixed-fonts srpm, not something else entirely.

Also as Jens wrote we need to de-duplicate with xorg-x11-fonts, but xorg-x11-fonts is another package that needs reorganisation
Comment 12 Nicolas Mailhot 2009-09-22 02:38:19 EDT
(In reply to comment #8)
 
> 3. and get Behdad to look at the other files and tell you if it's a bug his
> side or if the files need some form of fixing. Fontconfig won't be able to use
> them if it can't read the font name inside. The readme says they are Lucida but
> fontconfig does not read readmes. 

BTW due to a mock bug I checked the files in the srpm, not the files in the built rpm, so it may be that this is already fixed as part of the current build process (need to check the existing repo-font-audit tool for what it says about this package)
Comment 13 Pravin Satpute 2009-09-29 05:29:03 EDT
sorry for bit late update 

fc-scan works fine on all *.pcf files

i have done suggested changes updated spec and srpm are as follows

http://pravins.fedorapeople.org/bitmap-fonts/bitmap-fonts.spec
http://pravins.fedorapeople.org/bitmap-fonts/bitmap-fonts-0.3-10.fc11.src.rpm

also created a new package request for ucs-fixed-fonts

bug 526204
Comment 14 Pravin Satpute 2009-09-30 03:41:46 EDT
i have build bitmap-fonts-0_3-9_fc12, with spec submitted in comment #6

better to do update bitmap-fonts with merge review for F13 and also looks good to close this f12-blocker bug and do discussion on Merge Review on bug 225617
Comment 15 Pravin Satpute 2009-10-05 05:20:59 EDT
bitmap-fonts-0.3-9.fc12 successfully moved from dist-f12-updates-candidate into dist-f12
Comment 16 Pravin Satpute 2009-10-09 01:55:05 EDT
if any problem reopen bug

Note You need to log in before you can comment on or make changes to this bug.