Bug 481084 - Patch changing OFX version from 102 to 103 breaks access to citigroup credit cards
Patch changing OFX version from 102 to 103 breaks access to citigroup credit ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libofx (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 21:30 EST by archimerged Ark submedes
Modified: 2014-03-16 23:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 12:44:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description archimerged Ark submedes 2009-01-21 21:30:28 EST
Description of problem:  gnucash can't get transactions from
many citigroup credit cards because the OFX header version
was changed from 102 to 103

Version-Release number of selected component (if applicable):
libofx-0.8.3-7.i386

How reproducible:
every time.  The OFX header version is hard coded.

Steps to Reproduce:
1. Set up gnucash account so ~/.banking has citigroup user like the one given below
2. AQOFX_LOG_COMM=1 gnucash
3. Try to download transactions
  
Actual results:
/tmp/ofx.log has


Sending:
-------------------------------------
OFXHEADER:100

DATA:OFXSGML

VERSION:103

[...]



Received:
-------------------------------------
Can not find DTD Version Tree!



Expected results:

If you patch the version number to 102, the server responds as expected.

Additional info:

  user {
    int  uniqueId="85"
    char backendName="aqofxconnect"
    char userName="xxx"
    char userId="xxx"
    char customerId="xxx"
    char country="US"
    char bankCode="6642"
    int  lastSessionId="0"

    data {
      backend {
        char fid="24909"
        char org="Citigroup"
        char serverType="https"
        char serverAddr="https%3A%2F%2Fsecureofx2.bankhost.com%2Fciti%2Fcgi%2Dforte%2Fofx%5Frt?servicename%3Dofx%5Frt%26pagename%3Dofx"
        char flags="statements", "emptyBankId"
      } # backend
    } # data
  } # user
Comment 1 archimerged Ark submedes 2009-01-21 21:34:26 EST
Forgot to set version to Fedora 9.  Don't know if this has been changed in 10 or rawhide.
Comment 2 Bill Nottingham 2009-01-22 12:44:45 EST
Fedora 10 and rawhide should be fine. Unfortunately, fixing this properly requires changing the libofx ABI and changing all its users. Ergo, it can't really be backported to Fedora 9. Sorry.

Note You need to log in before you can comment on or make changes to this bug.