Bug 481129 - Amarok crashes with SIGSEV 11
Amarok crashes with SIGSEV 11
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 05:08 EST by Andreas Utterberg
Modified: 2009-02-04 14:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 14:08:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Utterberg 2009-01-22 05:08:42 EST
Description of problem:
Amarok crashes with SIGSEV 11 when clicking on Internet-Shoutcast Directory->Right click on a stream -> Copy to Location -> Local collection, just press ok on the dialog coming up.


Version-Release number of selected component (if applicable):
Fedora 10, KDE 4.1.3

rpm -qa | grep amarok
amarok-2.0.1.1-1.fc10.i386

How reproducible:
On every try

Steps to Reproduce:
1. Click on Internet
2. Click on Shoutcast directory
3. Expand a category
4. Right click on a stream
5, Choose Copy to Location
6. Choose Local collection
7. Press Ok in the dialog appearing.
  
Actual results:
SIGSEV 11 (Amarok crash)

Expected results:
?

Additional info:
Comment 1 Rex Dieter 2009-01-22 13:14:46 EST
I can't seem to reproduce, after Copy to Local collection... I can't find it in my Collection.
Comment 2 Steven M. Parrish 2009-02-04 08:46:48 EST
I am unable to reproduce on my system.  Is this still an issue?
Comment 3 Andreas Utterberg 2009-02-04 13:27:18 EST
I can still reproduce it with the steps above, running amarok as a normal user in a terminal with amarok -d produces following debug info:

(Snippet from the last ~40 lines)

amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 4.5e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 4.9e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 4.4e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 5.2e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 5.7e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 6.2e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 5.1e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 5e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 5.3e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 5e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 5.2e-05s
amarok: BEGIN: MetaStream::Track::Track(const KUrl&)
amarok: END__: MetaStream::Track::Track(const KUrl&) - Took 8.6e-05s
amarok: BEGIN: void ShoutcastServiceQueryMaker::handleResult()
amarok: END__: void ShoutcastServiceQueryMaker::handleResult() - Took 0.00037s
Object::connect: No such signal QWidget::accepted()
Object::connect:  (sender name:   'OrganizeCollectionDialogBase')
Object::connect:  (receiver name: 'FilenameLayoutDialog')
amarok: BEGIN: QStringList MountPointManager::collectionFolders()
amarok: END__: QStringList MountPointManager::collectionFolders() - Took 0.00016s
amarok: END__: void ShoutcastServiceQueryMaker::stationDownloadComplete(KJob*) - Took 2s
KCrash: Application 'amarok' crashing...
sock_file=/home/andutt/.kde/socket-thundera/kdeinit4__0


rpm -qa | grep amarok
amarok-2.0.1.1-1.fc10.i386
Comment 4 Rex Dieter 2009-02-04 13:35:40 EST
Report upstream please, I've no further ideas on how to debug this or to try to reproduce.
Comment 5 Andreas Utterberg 2009-02-04 13:47:24 EST
Upstream forum request filed here http://amarok.kde.org/forum/index.php/topic,16459.0.html, reportback here if any solution or other feedback is provided by the amarok team.
Comment 6 Rex Dieter 2009-02-04 14:08:31 EST
a report to bugs.kde.org against amarok would likely be preferred by them..., but ok.
Comment 7 Rex Dieter 2009-02-04 14:09:21 EST
I notice your forum post mentioned kde-4.1.3, please update to kde-4.1.4 in stable updates, to see if that helps.

Note You need to log in before you can comment on or make changes to this bug.