Bug 481131 - kio_smb is unable to handle shares and files with latin characters
kio_smb is unable to handle shares and files with latin characters
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-runtime (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On: kde42
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 05:30 EST by Alexis Deruelle
Modified: 2009-02-19 06:42 EST (History)
7 users (show)

See Also:
Fixed In Version: KDE 4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 06:42:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kubuntu_04_kiosmb.diff (1.38 KB, patch)
2009-01-22 08:11 EST, Alexis Deruelle
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 158639 None None None Never

  None (edit)
Description Alexis Deruelle 2009-01-22 05:30:50 EST
Description of problem:

kio_smb is unable to handle shares and files with latin characters ; see upstream bug https://bugs.kde.org/show_bug.cgi?id=158639

Version-Release number of selected component (if applicable):

kdebase-runtime-libs-4.1.4-1.fc10.i386 exhibit the issue

How reproducible: Always

Steps to Reproduce: browse to a smb share with latin characters in filenames and/or folders
  
Actual results: unable to browse or open files/folders

Expected results: would be able to browse or open files/folders

Additional info:

As reported in upstream bug #158639, the issue is fixed in KDE4.2.x branch but still not backported to KDE4.1.x. This issue is preventing many users in heterogeneous (ie corporate) environment from using KDE4 and fc10.

There's no information ATM on the timeline for an eventual backport.

Some distros are shipping patched version of KDE for this issue. Would be great to see the same in the upcoming KDE 4.1.4 for fc10 !
Comment 1 Kevin Kofler 2009-01-22 05:35:21 EST
4.1.4 is already pushed to stable. We're already working on a 4.2.0 update. That said, we have to push out an updated kdebase-runtime anyway to provide /usr/bin/kdesu, so we could add this fix there.
Comment 2 Kevin Kofler 2009-01-22 05:36:10 EST
(4.2.0 may take 2-3 weeks still, it is not even released officially yet and it will also need some time in updates-testing to detect and fix regressions.)
Comment 3 Alexis Deruelle 2009-01-22 08:11:07 EST
Created attachment 329710 [details]
kubuntu_04_kiosmb.diff

Here's the proposed patch from kubuntu if needded
Comment 4 Rex Dieter 2009-01-22 08:55:18 EST
If this a recent regression?  If not, why the rush (that can't wait for 4.2.0 coming real soon)?
Comment 5 Alexis Deruelle 2009-01-22 09:22:39 EST
If real soon is another month I think it's a real pain in the <add your favourite body part>. Did not bothered to complain here before as the bug has been reported loooong time ago upstream.

I'm really going crazy over this issue and I've been crying loud when I figured  such basic issue didn't got fixed in upstream 4.1.4.

Save my soul. Now.

Your latin script luser's, trully.
Comment 6 Rex Dieter 2009-01-22 09:35:05 EST
I understand your frustration, truly, and don't mean to belittle that.

My concerns are (in the least):
1.  the patch isn't ours or upstream's
2.  we/fedora doesn't currently have a developer/maintainer looking at this
3.  if we did, it wouldn't have much/any testing before 4.2.0 landed
4.  what time/effort we *do* have is focused on 4.2.0
Comment 7 Alexis Deruelle 2009-01-22 09:51:57 EST
Fair enough.

Can you update the bug as soon as 4.2.0 fc10 packages hit koji ?
Comment 8 Rex Dieter 2009-01-22 09:58:48 EST
absolutely.
Comment 9 Ngo Than 2009-01-28 08:33:54 EST
fixed in 4.2.0
Comment 10 Fedora Update System 2009-02-04 21:27:08 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdeedu-4.2.0-2.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdelibs-4.2.0-7.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kde-l10n kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 11 Alexis Deruelle 2009-02-05 08:11:06 EST
works for me.
Comment 12 Kevin Kofler 2009-02-05 08:24:50 EST
Please keep this open until the 4.2.0 update is actually stable.
Comment 13 Fedora Update System 2009-02-06 00:24:19 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 14 Fedora Update System 2009-02-07 17:21:04 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, kde-settings-4.1-6.20090206svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 kde-settings phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387

Note You need to log in before you can comment on or make changes to this bug.