Bug 481132 - Typo in spec file
Typo in spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 05:33 EST by Karsten Hopp
Modified: 2009-02-24 22:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 22:28:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2009-01-22 05:33:29 EST
Description of problem:
a rebuild of autofs leaves an empty directory 
/var/tmp/autofs-5.0.4-4.src.rpm-root%{initrddir}

This is caused by the line
mkdir -p -m755 $RPM_BUILD_ROOT%{initrddir}
in the spec file. The correct macro is %{_initrddir}


Version-Release number of selected component (if applicable):
autofs-5.0.4-4

Steps to Reproduce:
1. rebuild autofs
2. check /var/tmp directory

Additional info:
As this obviously isn't needed at all as the build would fail otherwise, the mkdir line can be removed.
Comment 1 Ian Kent 2009-01-22 06:08:20 EST
Interesting, wonder why the build still works ok.
Maybe because the "make install ..." later creates it, in fact
that should be true all those directories, except maybe the sbin
dir.
Comment 2 Fedora Admin XMLRPC Client 2009-02-24 11:15:37 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Ian Kent 2009-02-24 21:28:44 EST
I would prefer to leave the mkdir in place and correct the
macro. That's what I'll do.
Comment 4 Ian Kent 2009-02-24 22:28:04 EST
I've made this change and the build seems to clean up after
itself now.

This change in included in revision 16 of the Rawhide autofs
package.

Note You need to log in before you can comment on or make changes to this bug.