Bug 481133 - Cluster services do not come back to primary location in accordance with failoverdomain
Cluster services do not come back to primary location in accordance with fail...
Status: CLOSED DUPLICATE of bug 462679
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 05:42 EST by Yaroslav Ischenko
Modified: 2009-04-16 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 09:43:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cluster config (5.02 KB, text/plain)
2009-01-22 05:42 EST, Yaroslav Ischenko
no flags Details
Log from node2.lab (3.79 KB, text/plain)
2009-01-22 05:43 EST, Yaroslav Ischenko
no flags Details
Log from node3.lab (4.61 KB, text/plain)
2009-01-22 05:44 EST, Yaroslav Ischenko
no flags Details

  None (edit)
Description Yaroslav Ischenko 2009-01-22 05:42:20 EST
Created attachment 329704 [details]
Cluster config

Description of problem:
Cluster services do not move back to primary location after main node restoration

Version-Release number of selected component (if applicable):
CentOS-5.2
kernel-2.6.18-92.1.13.el5.028stab059.6xen (x86, XEN + OpenVZ)
openais-0.80.3-15.el5
cman-2.0.84-2.el5_2.3
rgmanager-2.0.38-2.el5_2.1


How reproducible:
Cluster hosts: node1.lab, node2.lab, node3.lab, node4.lab
iSCSI storage host: stor1.lab
Cluster services: vps01, vps02, vps03



Steps to Reproduce:
1. Start cluster - node1.lab, node2.lab, node3.lab, node4.lab
2. Stop nodes - node4.lab, node2.lab, node1.lab
3. Start node2.lab
  
Actual results:
Cluster services vps01 and vps02 are still running at node3.lab

Expected results:
Cluster services vps01 and vps02 should relocate to node2.lab accordingly failoverdomain dom2



Additional info:
Additional node2.lab reboot relocate cluster services to their appropriate location.
Comment 1 Yaroslav Ischenko 2009-01-22 05:43:31 EST
Created attachment 329705 [details]
Log from node2.lab
Comment 2 Yaroslav Ischenko 2009-01-22 05:44:17 EST
Created attachment 329706 [details]
Log from node3.lab
Comment 3 Lon Hohberger 2009-01-22 09:43:28 EST
So, there's an event trigger bug in 5.2 that's fixed in 5.3 which is very likely the cause of this:

https://bugzilla.redhat.com/show_bug.cgi?id=462679

*** This bug has been marked as a duplicate of bug 462679 ***

Note You need to log in before you can comment on or make changes to this bug.