Bug 481149 - Change log view page can't display Unicode characters in package change log
Change log view page can't display Unicode characters in package change log
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
520
All Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Lestach
Jiří Mikulka
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2009-01-22 08:15 EST by Radek Bíba
Modified: 2014-10-06 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2009-01-22 08:15:20 EST
Description of problem:
My name was mentioned in ethtool-6.2.el5 change log (note the Unicode í), rpm -q --changelog displays it just fine, but when looking at it via the satellite change log view page, Ã is displayed instead.

And it's not just this case, wireshark is maintained by Radek Vokál, and Satellite mutilates his name, too.

I don't see this on RHN Live, though:
https://rhn.redhat.com/network/software/packages/change_log.pxt?pid=470056

which makes me think it's a Satellite-only bug.

Version-Release number of selected component (if applicable):
Red Hat Network release 5.2.0
Comment 2 Tomas Lestach 2013-05-30 08:06:45 EDT
The changelog page was migrated from perl to java and optimized in the meantime.

Looking at current sputnik-prod (v5.5):

https://sputnik-prod.brq.redhat.com/rhn/software/packages/ChangeLog.do?pid=75727
- Include patch from Radek Bíba (rbiba@redhat.com) to close

https://sputnik-prod.brq.redhat.com/rhn/software/packages/ChangeLog.do?pid=23332
* Thu Nov 23 2006 Radek Vokal <rvokal@redhat.com> 0.99.4-2
* Wed Nov 01 2006 Radek Vokál <rvokal@redhat.com> 0.99.4-1
(but this is exactly as rpm -q --changelog shows)


Switching to ON_QA to go through the QA.
Comment 4 Clifford Perry 2013-10-01 17:54:11 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.