Bug 481156 - S-c-language crashes while installing new language - zero division error
S-c-language crashes while installing new language - zero division error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 480902
  Show dependency treegraph
 
Reported: 2009-01-22 09:19 EST by Jaroslav Reznik
Modified: 2009-11-02 23:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 23:28:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2009-01-22 09:19:05 EST
Description of problem: S-c-language crashes while installing new language with traceback zero division error.


Version-Release number of selected component (if applicable): system-config-language-1.3.2-3.fc10.noarch


How reproducible: install new language support, occurred once


Steps to Reproduce:
1. select new language, click ok
2. let new language install in the next dialog
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/system-config-language/gui_progress.py", line 101, in callback
    pct = amount/float(total)
ZeroDivisionError: float division
error: python callback <bound method GuiTransactionProgress.callback of <gui_progress.GuiTransactionProgress instance at 0x7f0a28085200>> failed, aborting!

Expected results:
S-c-language not crashing
Comment 1 Pravin Satpute 2009-01-23 02:41:19 EST
its working fine at my end,
it crashing while selecting which language?
Comment 2 Jaroslav Reznik 2009-01-23 10:39:14 EST
Hmm, I can't reproduce it now too after uninstalling language support (Greek) and installing it again.
Comment 3 Jaroslav Reznik 2009-01-24 10:24:52 EST
Ok, so I can 100% reproduce it while selecting Czech language support and s-c-language is used for first time. Checked on to different installations from KDE Live F10 CD. So sorry for misleading by Greek, it's Czech, I wasn't sure.
Comment 4 Pravin Satpute 2009-01-27 05:37:57 EST
no props,
yeah it is giving above mentioned error
i am checking for that
thanks for filing bug
Comment 5 Pravin Satpute 2009-10-23 03:18:51 EDT
looks better in rawhide
can you check it once?
Comment 6 Jaroslav Reznik 2009-11-02 10:43:42 EST
Hi,
it's not crashing anymore.

Thank you, you can close this bug, in case of reappearance of this issue, I'll reopen it. But I hope it's OK now.
Comment 7 Pravin Satpute 2009-11-02 23:28:22 EST
thanks Jaroslav.

Note You need to log in before you can comment on or make changes to this bug.