Bug 481179 - pirut package lists do not sort packages using locale specific infromation
pirut package lists do not sort packages using locale specific infromation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.3
All Linux
low Severity low
: beta
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 11:24 EST by Karel Volný
Modified: 2013-04-12 16:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 16:01:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the error (98.17 KB, image/png)
2009-01-22 11:24 EST, Karel Volný
no flags Details
Fix for pirut (and pirut in anaconda) sorting by "packages strings" (2.23 KB, patch)
2009-01-23 10:00 EST, James Antill
no flags Details | Diff

  None (edit)
Description Karel Volný 2009-01-22 11:24:23 EST
Created attachment 329720 [details]
screenshot of the error

Description of problem:
during system installation, when selecting individual packages, these are sorted in alphabetical order, but accented letters are put after the letter Z

this may seem as some packages are missing ...

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start system installation
2. select non English locale which uses accented letters (e.g. Czech)
3. choose to modify packages list immediately
4. choose Languages and scroll the list below letter Z
  
Actual results:
see the attached screenshot

Expected results:
A+acute is between A and B, C+caron is between C and D ...

Additional info:
Comment 1 Karel Volný 2009-01-23 06:16:43 EST
changing summary to match the correct component ... sorry, I did not realize that it is a package manager run by the installer and not the installer itself, as I prefer using commandline yum

so the error is reproducible anytime running pirut, not just during installation
Comment 2 James Antill 2009-01-23 10:00:24 EST
Created attachment 329843 [details]
Fix for pirut (and pirut in anaconda) sorting by "packages strings"

This is the fix we've tested internally. It might go out for 5.4
Comment 3 James Antill 2009-01-23 10:02:32 EST
Ok, this bug is different ...
Comment 9 Linda Wang 2010-09-17 12:12:21 EDT
The issue with "accented letters are put after the letter Z" is
due to the ascii [ISO 8859-1 and ISO 8859-2 of the international
standards] value of the characters.

ISO 8859-1 is West European languages (Latin-1)
ISO 8859-2 is Central and East European languages (Latin-2)

The ascii value of 'A-Z' is decimal value of '64 to 90';
and the "acute" accented 'A' has the value of '193':

Oct   Dec   Hex   Char   Description:
-------------------------------------
300   192   C0     À     LATIN CAPITAL LETTER A WITH GRAVE
301   193   C1     Á     LATIN CAPITAL LETTER A WITH ACUTE

Therefore, the sorting/ordering of the letters [component names] 
are corrected based on the international standards.

Hence, this issue should be closed as NOTABUG.
Comment 11 Karel Volný 2012-08-03 05:21:07 EDT
(In reply to comment #9)
> The issue with "accented letters are put after the letter Z" is
> due to the ascii [ISO 8859-1 and ISO 8859-2 of the international
> standards] value of the characters.

ahem, aren't we using Unicode (UTF-8) rather then those of ISO-8859 family?

> Therefore, the sorting/ordering of the letters [component names] 
> are corrected based on the international standards.

as far as my knowledge of those standards go, these are all about _encoding_ characters, not about _sorting_

these are two distinct things

to quote http://www.unicode.org/faq/collation.html

"Linguistically meaningful sorting is done not by comparing code point values (an approach which would fail even for English) ..."

> Hence, this issue should be closed as NOTABUG.

considering which version this concerns and how long this was untouched, I'd agree on closing - but rather WONTFIX
Comment 12 James Antill 2013-03-14 16:01:45 EDT
This should be fixed in the RHEL-6 package GUI.

This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.

Note You need to log in before you can comment on or make changes to this bug.