Bug 481218 - squashfs-tools cannot be run on big-endian systems
squashfs-tools cannot be run on big-endian systems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squashfs-tools (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-01-22 15:33 EST by Josh Boyer
Modified: 2009-01-28 15:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 15:58:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Boyer 2009-01-22 15:33:54 EST
Description of problem:

With the update to the version of squashfs-tools that support the squasfs 4 disk layout, mksquashfs fails to run on big-endian systems due to a hard coded assert.

This is due to the fact that byte swapping is not working (or implemented?) yet and the on-disk layout is little-endian.

Version-Release number of selected component (if applicable):

squashfs-tools-4.0-*

How reproducible:

Always

Steps to Reproduce:
1. Just try to run mksquashfs
2.
3.
  
Actual results:

FATAL ERROR:Swapping is not supported!


Expected results:

I dunno.  It actually works?

Additional info:

This is mostly just a tracker bug on the issue since it's an upstream problem.
Comment 1 Jeremy Katz 2009-01-28 15:58:08 EST
Kyle updated and this should be fixed now I think

Note You need to log in before you can comment on or make changes to this bug.