Bug 481221 - bluetoothd can't write class of device Belkin USB Bluetooth F8T009
bluetoothd can't write class of device Belkin USB Bluetooth F8T009
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 15:46 EST by Dave Hindle
Modified: 2009-08-13 11:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 11:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Hindle 2009-01-22 15:46:00 EST
Description of problem:

This USB bluetooth adapter has been supported by various versions of the kernel and bluez for some time but is not working in FC10.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. tail -f /var/log/messages
2. insert adapter
  
Actual results:

Jan 22 16:26:39 localhost kernel: usb 3-2: new full speed USB device using uhci_hcd and address 2
Jan 22 16:26:39 localhost kernel: usb 3-2: configuration #1 chosen from 1 choice
Jan 22 16:26:39 localhost kernel: usb 3-2: New USB device found, idVendor=0a5c, idProduct=200a
Jan 22 16:26:39 localhost kernel: usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 22 16:26:39 localhost kernel: usb 3-2: Product: Belkin Bluetooth Device
Jan 22 16:26:39 localhost kernel: usb 3-2: Manufacturer: Broadcom
Jan 22 16:26:39 localhost kernel: usb 3-2: SerialNumber: 000A3A62F2E5
Jan 22 16:26:45 localhost kernel: Bluetooth: Generic Bluetooth USB driver ver 0.3
Jan 22 16:26:45 localhost kernel: usbcore: registered new interface driver btusb
Jan 22 16:26:46 localhost bluetoothd[1923]: HCI dev 0 registered
Jan 22 16:26:46 localhost bluetoothd[1923]: HCI dev 0 up
Jan 22 16:26:47 localhost bluetoothd[1923]: Starting security manager 0
Jan 22 16:26:47 localhost bluetoothd[1923]: Registered interface org.bluez.Service on path /org/bluez/1923/hci0
Jan 22 16:26:47 localhost kernel: Bluetooth: RFCOMM socket layer initialized
Jan 22 16:26:47 localhost kernel: Bluetooth: RFCOMM TTY layer initialized
Jan 22 16:26:47 localhost kernel: Bluetooth: RFCOMM ver 1.10
Jan 22 16:26:52 localhost bluetoothd[1923]: Can't write class of device: Unknown error 4294967186 (-110)
Jan 22 16:26:52 localhost kernel: hci_cmd_task: hci0 command tx timeout

Expected results:


Additional info:
Comment 1 Bastien Nocera 2009-01-23 04:56:37 EST
This is a kernel problem with the device. Reassigning.
Comment 2 Neil Bird 2009-01-26 03:26:04 EST
I'm seeing the same thing after upgrading from F8 to F10:

Bus 001 Device 031: ID 0a5c:200a Broadcom Corp. Bluetooth dongle

E.g.:
2009-01-18T13:52:50.268153+00:00 host bluetoothd[27158]: Bluetooth daemon
2009-01-18T13:52:50.278104+00:00 host bluetoothd[27158]: Starting SDP server
2009-01-18T13:52:50.281282+00:00 host bluetoothd[27158]: Parsing /etc/bluetooth/network.conf failed: No such file or directory
2009-01-18T13:52:50.282296+00:00 host bluetoothd[27158]: bridge pan0 created
2009-01-18T13:52:50.282921+00:00 host bluetoothd[27158]: Parsing /etc/bluetooth/audio.conf failed: No such file or directory
2009-01-18T13:52:50.283441+00:00 host bluetoothd[27158]: Parsing /etc/bluetooth/input.conf failed: No such file or directory
2009-01-18T13:52:50.283720+00:00 host bluetoothd[27158]: Registered interface org.bluez.Service on path /org/bluez/27158/any
2009-01-18T13:52:50.283833+00:00 host bluetoothd[27158]: HCI dev 0 registered
2009-01-18T13:52:50.285481+00:00 host bluetoothd[27158]: HCI dev 0 already up
2009-01-18T13:52:50.285973+00:00 host bluetoothd[27158]: Starting security manager 0
2009-01-18T13:52:55.286153+00:00 host bluetoothd[27158]: Can't read version info for /org/bluez/27158/hci0: Unknown error 4294967186 (-110)
2009-01-18T13:53:00.284198+00:00 host bluetoothd[27163]: Can't set link policy on hci0: Connection timed out (110)
Comment 3 Chuck Ebbert 2009-01-29 00:39:38 EST
Looks like error -110 is coming from the USB subsystem.
Comment 4 Joshua Valenter 2009-06-25 13:37:58 EDT
[root@fedora ~]# uname -a
Linux fedora 2.6.29.5-191.fc11.i686.PAE #1 SMP Tue Jun 16 23:19:53 EDT 2009 i686 i686 i386 GNU/Linux

[root@fedora ~]# hcitool scan
Scanning ...
Inquiry failed: Connection timed out

dmesg:
Bluetooth: Core ver 2.15
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: Generic Bluetooth USB driver ver 0.5
Bluetooth: L2CAP ver 2.13
Bluetooth: L2CAP socket layer initialized
Bluetooth: SCO (Voice Link) ver 0.6
Bluetooth: SCO socket layer initialized
Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Bluetooth: BNEP filters: protocol multicast
Bridge firewalling registered
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.11
usb 4-1: new full speed USB device using uhci_hcd and address 4
usb 4-1: New USB device found, idVendor=0a5c, idProduct=200a
usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 4-1: Product: Belkin Bluetooth Device
usb 4-1: Manufacturer: Broadcom
usb 4-1: SerialNumber: 000A3A6862A1
usb 4-1: configuration #1 chosen from 1 choice
hci_cmd_task: hci0 command tx timeout

/var/log/messages:
Jun 25 20:31:45 fedora bluetoothd[5640]: Bluetooth daemon 4.37
Jun 25 20:31:45 fedora bluetoothd[5640]: Starting SDP server
Jun 25 20:31:45 fedora bluetoothd[5640]: Parsing /etc/bluetooth/audio.conf failed: No such file or directory
Jun 25 20:31:45 fedora bluetoothd[5640]: Parsing /etc/bluetooth/network.conf failed: No such file or directory
Jun 25 20:31:45 fedora bluetoothd[5640]: bridge pan0 created
Jun 25 20:31:45 fedora bluetoothd[5640]: Parsing /etc/bluetooth/input.conf failed: No such file or directory
Jun 25 20:31:49 fedora bluetoothd[5640]: HCI dev 0 registered
Jun 25 20:31:49 fedora bluetoothd[5640]: HCI dev 0 up
Jun 25 20:31:49 fedora bluetoothd[5640]: Starting security manager 0
Jun 25 20:32:00 fedora bluetoothd[5640]: Can't write class of device: Connection timed out (110)
Jun 25 20:32:00 fedora bluetoothd[5640]: Adapter /org/bluez/5640/hci0 has been enabled
Jun 25 20:32:05 fedora bluetoothd[5640]: Sending getting name command failed: Connection timed out (110)
Jun 25 20:32:10 fedora bluetoothd[5640]: Can't read class of device on hci0: Connection timed out (110)
Comment 5 Joshua Valenter 2009-06-26 03:59:03 EDT
I updated to rawhide and I'm still using the same 2.6.29.5-191.fc11.i686.PAE kernel. The Bluetooth dongle seems to work better now since Nokia 770 sees my laptop. For some reason my laptop doesn't see Nokia 770 device but there's probably something wrong with the 770's configures.

1. tail -f /var/log/messages
2. insert adapter

Jun 26 10:54:28 fedora kernel: usb 4-1: new full speed USB device using uhci_hcd and address 4
Jun 26 10:54:28 fedora kernel: usb 4-1: New USB device found, idVendor=0a5c, idProduct=200a
Jun 26 10:54:28 fedora kernel: usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jun 26 10:54:28 fedora kernel: usb 4-1: Product: Belkin Bluetooth Device
Jun 26 10:54:28 fedora kernel: usb 4-1: Manufacturer: Broadcom
Jun 26 10:54:28 fedora kernel: usb 4-1: SerialNumber: 000A3A6862A1
Jun 26 10:54:28 fedora kernel: usb 4-1: configuration #1 chosen from 1 choice
Jun 26 10:54:28 fedora bluetoothd[1878]: HCI dev 0 registered
Jun 26 10:54:28 fedora bluetoothd[1878]: HCI dev 0 up
Jun 26 10:54:28 fedora bluetoothd[1878]: Starting security manager 0
Jun 26 10:54:34 fedora kernel: hci_cmd_task: hci0 command tx timeout
Jun 26 10:54:34 fedora bluetoothd[1878]: Adapter /org/bluez/1873/hci0 has been enabled

Please, let me know if there's anything that I can do to get this bug solved.
Comment 6 Joshua Valenter 2009-06-26 08:29:32 EDT
(In reply to comment #5)
>. For some reason my laptop doesn't see Nokia 770 device but there's probably something wrong
> with the 770's configures.

Yes, it was just a configure problem. The dongle seems to work OK on rawhide with Fedora 11 kernel.

[root@fedora ~]# uname -a
Linux fedora 2.6.29.5-191.fc11.i686.PAE #1 SMP Tue Jun 16 23:19:53 EDT 2009 i686 i686 i386 GNU/Linux
Comment 7 Pete Zaitcev 2009-08-09 21:15:44 EDT
Can we close this?

Note You need to log in before you can comment on or make changes to this bug.