Bug 481225 - random key-repeats and shift key causes shift-lock
random key-repeats and shift key causes shift-lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 16:16 EST by Heather Keen
Modified: 2009-11-03 15:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-03 15:36:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heather Keen 2009-01-22 16:16:20 EST
Description of problem:

Ever since installing the hal update 0.5.12-14.20081027git.fc10, I have encountered the following two problems:

1. Key repeats keep occurring and random intervals for no apparent reason. e.g. you are typing and suddenly one of the characters you are typing suddenly repeats itself constantly until you press another key to stop it.

2. When pressing the shift key sometimes it turns on shift lock.  All key presses from this point on are as if the shift key has been held down.  It is only resolved by pressing the shift key again.  This may well be the same problem as the key-repeat issue above.

Both of these events occur in any application, e.g. xterm, gnome-terminal, openoffice, thunderbird, firefox, etc.

Version-Release number of selected component (if applicable):
0.5.12-14.20081027git.fc10

How reproducible:
This is not reproduceable on demand - it seems to happen randomly, but often.

Additional info:
I don't have any unusual hardware - just a bog standard 105-key keyboard and an optical mouse, however they are connected via a KVM.  But they were working fine prior to this update.
Comment 1 John Ellson 2009-02-04 21:16:50 EST
I'm seeing very similar key repeat symptoms, but only in SecondLife.   I haven't seen the repeats in other applications (yet).

For me it happens after about five minutes in the application.

x86_64, Rawhide, using NVidia drivers.
Comment 2 John Himpel 2009-02-10 14:01:56 EST
I was just wondering if there was any hint of a workaround on this issue.  It affects me on all X-based applications and well as CLI (plain old "login"/bash shell) applications.  It takes 10 minutes to enter a single line of text (with unresponsive keyboard pauses and repeated characters).  I tried reverting Hal back to the F10 original version, but there was no change.  I can ssh into the afflicted workstation from another workstation (PPC based) and there are no similar symptoms.  I connected via usb keyboard.  There is no KVM. I am up-to-date with the latest Rawhide packages.  Any kind of status report from Richard would be greatly appreciated.  Let me know how I can help.
Comment 3 John Ellson 2009-02-18 18:37:36 EST
My "similar" symptoms on rawhide seem to have gone away today.   I can't tell you what rpm cured it.

I was just about to write up a workaround which I found yesterday:
    System->Preferences->Assistive Technologies
       ->Keyboard Accessibility
           + Only accept long kepresses, with shortest delay
           + Ignore fast duplicate keypresses, with shortest delay
                       all Audio Feddback disabled


This worked for me yesterday.  I went try to recreate the original config
today for this write up, but all these config settings had been lost and the 
problem wasn't occurring.   GConf2 ???
Comment 4 Heather Keen 2009-02-20 04:59:25 EST
My symptoms had eased over the past couple of weeks, I wasn't getting the key-repeat occurring, but I was still getting the "sticky" shift and ctrl key problems.

And then I installed all the updates that were released yesterday (incl. the kernel update) ... and now it's back to how it was in January. :(

[I have kept my machine up-to-date with all the patches as and when they become available.]
Comment 5 Scott Glaser 2009-09-09 08:47:51 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Heather Keen 2009-11-03 10:00:48 EST
Hi, sorry yes.  The problem seems to have gone away now.

HAL version is hal-0.5.12-14.20081027git.fc10.i386.

Thanks.
Comment 7 Scott Glaser 2009-11-03 15:36:41 EST
Based on the information in Comment #6 I am closing this bug as CLOSED ERRATA, should you experience this issue again in the future feel free to file a new bug against the appropriate component.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.