Bug 481229 - Ship stable mono
Ship stable mono
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 16:39 EST by Michael Monreal
Modified: 2009-04-17 15:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 15:29:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2009-01-22 16:39:37 EST
Rawhide currently ships a pre-2.4.0 mono snapshot. Considering 2.2 was just released a week ago and Fedora 11 Alpha is just around the corner (there is no way F11 will ship anything newer than 2.2) I consider this bug-worthy.

Also note that a few modules (Banshee, Tomboy) don't compile even with mono 2.2 atm so fixing this before F11 Alpha should be a priority.
Comment 1 Paul F. Johnson 2009-01-23 02:16:30 EST
The purpose of rawhide is to include the bleeding edge material. It currently has 2.4svn in there and pre 1 won't be out for a while. The version I import goes through a huge series of tests before I upload, so I'm happy with it's stability (and by huge, there are almost 1200 tests I use, if it fails more than 5% I don't let it out).

If Banshee and Tomboy don't build with 2.2 then I would suggest opening a bug here and also upstream as the fault could lie in either camp.
Comment 2 Michael Monreal 2009-01-23 04:48:33 EST
Well generally I agree to have bleeding edge stuff in Rawhide, but won't the next Fedora be "cut" from Rawhide at some point soon? Or will you base F11 packages off F10 when the Alpha is released?

Thing is I want Banshee and Tomboy to work in F11 as soon as possible and I know they currently both have problems because I built them myself using jhbuild. But trying to fix stuff is hard with a moving "base technology" target. IMHO resolving this before things breaks for the first "real" users would be a good idea.

I know bugzilla is probably a bad place for this kind of discussion... is there a mono-on-fedora mailing list or IRC channel?
Comment 3 Toshio Ernie Kuratomi 2009-04-17 15:29:30 EDT
http://fedoraproject.org/wiki/SIGs/Mono

In particular: https://admin.fedoraproject.org/mailman/listinfo/fedora-mono

I'm going to close this bug as backing out mono-2.4 to a mono-2.2 release at this point in the Fedora 11 release schedule is not feasible.  Since mono seems to have adopted a fairly aggressive release schedule, this is likely something that needs to be discussed on the list for Fedora 12 as well so I hope to see you bring it up there.

Note You need to log in before you can comment on or make changes to this bug.