Bug 481252 - libedit-devel should require ncurses-devel
libedit-devel should require ncurses-devel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libedit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 478466
  Show dependency treegraph
 
Reported: 2009-01-22 22:40 EST by Jens Petersen
Modified: 2009-02-04 21:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 21:21:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-01-22 22:40:09 EST
Description of problem:
libedit requires ncurses and reflecting that libedit-devel should require ncurses-devel.

Version-Release number of selected component (if applicable):
libedit-2.11-1.20080712cvs.fc10

Steps to Reproduce:
This is causing a problem for ghc (Haskell compiler) when trying to link its editline library which is linked to libedit.

Actual results:
$ rpm -q --requires libedit | grep ncurses
libncurses.so.5()(64bit)  
$ rpm -q --requires libedit-devel | grep ncurses
$

Expected results:
libedit to require ncurses-devel. 

Additional info:
I note that libedit-20090111-3.0 was also released upstream.

I am happy to fix and update the package if you don't have time.
Comment 1 Jeffrey C. Ollie 2009-01-23 01:02:50 EST
I've added ncurses-devel as a requirement for libedit-devel and issues builds/updates.  Updating to libedit-20090111-3.0.  I'm less sure about.  I know it's a ways off but perhaps it'd be better to wait and put 3.0 into rawhide once it switches over to F12 development.
Comment 2 Jens Petersen 2009-01-23 02:19:31 EST
Thanks, Jeff, appreciate the fast response. :)

I'll move this to F10 so that it can closed when the update gets pushed.
Comment 3 Debarshi Ray 2009-01-23 02:59:11 EST
(In reply to comment #1)
> I've added ncurses-devel as a requirement for libedit-devel and issues
> builds/updates.

Thanks for helping out.

>  Updating to libedit-20090111-3.0.  I'm less sure about.  I
> know it's a ways off but perhaps it'd be better to wait and put 3.0 into
> rawhide once it switches over to F12 development.

Looking at the following ChangeLog entry, it does not look like that big a change in the library even though the soname has changed. I am inclined to wait till Alpha is out and then evaluate the effect on all dependent packages, and if possible push out an update before Beta.

----
2009-01-11  Jess Thrysoee

   * version-info: 0:28:0

   * all: sync with upstream source. MAJOR.MINOR version is now 3.0.
	This is due to NetBSD changing time_t and dev_t to 64 bits. It does
	not really effect this package.

   * configure.ac: Remove '--enable-debug' configure flag. The autoconf way
	to control flags is by specifying them when running configure,
	e.g. 'CFLAGS="-O0 -g" ./configure'
----

What do you think?
Comment 4 Fedora Update System 2009-01-23 21:39:53 EST
libedit-2.11-2.20080712cvs.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update libedit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0922
Comment 5 Fedora Update System 2009-01-23 21:40:36 EST
libedit-2.11-2.20080712cvs.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libedit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0924
Comment 6 Jeffrey C. Ollie 2009-01-23 22:02:40 EST
(In reply to comment #3)
>
> Looking at the following ChangeLog entry, it does not look like that big a
> change in the library even though the soname has changed. I am inclined to wait
> till Alpha is out and then evaluate the effect on all dependent packages, and
> if possible push out an update before Beta.

After the Alpha is out should be OK.  Only the minor revision of the soname changed so there shouldn't be any broken dependencies if we push it - I did a test mock build of 3.0 but I didn't install it.  There's around 80 days until the final release so that should be plenty of time to shake out any problems, when I first commented I didn't realize that we had that long.
Comment 7 Fedora Update System 2009-02-04 21:21:31 EST
libedit-2.11-2.20080712cvs.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.