Bug 481275 - Desktop limited to 4 workspaces?
Summary: Desktop limited to 4 workspaces?
Keywords:
Status: CLOSED DUPLICATE of bug 382901
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-desktop
Version: 10
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-23 11:44 UTC by Gary Thomas
Modified: 2009-08-26 12:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-26 12:19:04 UTC


Attachments (Terms of Use)
Workspace preference dialog (217.38 KB, image/png)
2009-01-25 07:28 UTC, Gary Thomas
no flags Details

Description Gary Thomas 2009-01-23 11:44:36 UTC
Description of problem:
It seems that Gnome in Fedora 10 limits the user to 4 virtual desktops (workspaces).  This was much larger in previous versions (I commonly use 12).

How do I get the previous behaviour back?
What about keyboard shortcuts for switching workspaces?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matthias Clasen 2009-01-25 00:46:43 UTC
Right-click on the workspace switcher (the applet showing you a miniature view of your workspaces), open preferences, change number of workspaces.

Comment 2 Gary Thomas 2009-01-25 07:28:01 UTC
Created attachment 329928 [details]
Workspace preference dialog

This screenshot shows that the options to change the number of workspaces
is gone in Fedora 10

Comment 3 Gary Thomas 2009-01-26 12:26:27 UTC
Interestingly, that screenshot came from my [freshly insalled] HP laptop.
I've now installed on a desktop (Dell PowerEdge 2950 server) and when I run
this dialogue, I get a completely different set of options, including the
number of workspaces.  What gives?

My laptop display is 1280x800 (24 bit)
The Dell server is 1280x960 (24 bit)

Both systems are 100% fresh installs (with current updates)

I used to run 12 workspaces on this HP laptop, up to and including Fedora 8

Could this have anything to do with enabling the desktop effects?  I did that,
just to see what it did (frankly I'm not all that thrilled), but I don't see
any way in the "Look & Feel"/"Desktop Effects" dialogue to turn them off 100%
(all I see is how to disable them individually).

Side note: when I tried to enable the desktop effects on the Dell server,
the screen went white for about 2 minutes :-(  Then the effects checkboxes
stayed grey, indicating that they weren't available.  This is what led to
the question/observation above.

Comment 4 Oded Arbel 2009-03-05 12:52:43 UTC
When desktop effects is enabled, the workspace switcher's "number of workspaces" configuration option are not available (as in the screenshot). 

Here is the issue ticket in Ubuntu's launchpad: https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/141210 , which claims that a fix was released for GNOME 2.20. From looking at a current Ubuntu then the workspace switchers configuration dialog looks different when compiz is enabled but it still lets you configure the number of workspaces while with Fedora's GNOME the workspace switcher's configuration also looks different when compiz is enabled but it WILL NOT let you set the number of workspaces.

This is verified on Fedora 11 Alpha

The following Redhat bugzilla bugs may be relevant: Bug 382901 , Bug 479478. I haven't found any relevant GNOME bugzilla bugs.

To work around the issue, install 'ccsm', then under System->Preferences->Look & Feel choose "CompizConfig Settings Manager". In the new window choose "General Options" and from the tab list choose "Desktop Size" and change the top slider to how many workspaces you need. This will not change the number of workspaces immediately - you'd need to log out and log in again.

Comment 5 Vedran Miletić 2009-06-16 13:48:56 UTC
Please close this bug as a duplicate of bug 382901.

Comment 6 Vedran Miletić 2009-08-26 12:19:04 UTC

*** This bug has been marked as a duplicate of bug 382901 ***


Note You need to log in before you can comment on or make changes to this bug.