Bug 481278 - Java applet at http://aladin.u-strasbg.fr/java/nph-aladin.pl doesn't start in firefox
Java applet at http://aladin.u-strasbg.fr/java/nph-aladin.pl doesn't start in...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
http://aladin.u-strasbg.fr/java/nph-a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 07:02 EST by Roderick Johnstone
Modified: 2009-04-01 17:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 17:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roderick Johnstone 2009-01-23 07:02:00 EST
Description of problem:
java applet at: http://aladin.u-strasbg.fr/java/nph-aladin.pl doesn't start in firefox. At the bottom left of the browser are the words "starting applet..." and a grey rectangle is displayed where the output of the java applet should be.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.x86_64

How reproducible:


Steps to Reproduce:
1. Start Firefox
2. Browse to http://aladin.u-strasbg.fr/java/nph-aladin.pl 
3.
  
Actual results:
firefox displays "starting applet..." for ever and a grey rectangle is displayed in the browser window where the output from the java applet should be.

Expected results:
Output from java applet should be displayed in browser.

Additional info:
Seems to work fine in 32-bit opera with sun java jdk1.6.0_11 and sun java plugin.
Comment 1 Deepak Bhole 2009-01-23 09:51:03 EST
Did you try restarting the browser after it hung? It hung for me the first time too, because it was waiting for a server response .. after restarting however, the applet loaded correctly. 

I can consistently reproduce the hang after clearing the cache each time, and will look into it.
Comment 2 Roderick Johnstone 2009-01-23 10:31:02 EST
Different things seem to happen different times I try.

Usually although closing the browser closes the browser window, the firefox process is still running as is a java process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/../../bin/java sun.applet.PluginMain

I have to kill these explicitly.

Next time I start firefox it doesn't display the applet.

Once when I reloaded the page I got a page asking me to accept a certificate. But after that it still didnt start the applet.

I've also tried clearing the cache and reloading the page but that didnt seem to help.

I did get the applet working once after some sequence that I cant remember.

 And now I've just had an empty window pop up called JavaEmbeddedFrame.

The behaviour  doesn't seem very consistent.

Thanks for looking into this.
Comment 3 Deepak Bhole 2009-01-23 16:05:34 EST
Hmm, okay, I am able to always reproduce the anomalous behaviour with the version of the plugin in Fedora 10 (I was trying it on a dev box before). In the current upstream version (which will be in Fedora 10 and rawhide soon), it rarely hangs, and even that hang is only during the first run. Once the jar is cached, it always runs fine.

Now that I have the applet loaded, I am wonder if it is working though. Can you suggest anything I can quickly try to make sure it is working correctly?
Comment 4 Roderick Johnstone 2009-01-23 16:15:19 EST
In the Command box at the top type eg NGC 1275 and press return. You should get a sky image with several large galaxies in  it and a pile of red circles and arrows overlaid on the objects.
Comment 5 Deepak Bhole 2009-01-23 16:22:32 EST
Cool, that works for me! So the applet should be usable with the new OpenJDK update. The initial stall is rather annoying though. I am going to keep this bug open until I investigate further/fix it.
Comment 6 Roderick Johnstone 2009-01-24 10:26:03 EST
Thanks for checking this out. I'll look out for the OpenJDK update. I guess it'll be in updates-testing first.
Comment 7 Deepak Bhole 2009-04-01 17:26:57 EDT
Update is in F10 now. Closing..

Note You need to log in before you can comment on or make changes to this bug.