Bug 481291 - firefox crashes when ICNS file is selected in file chooser dialog
firefox crashes when ICNS file is selected in file chooser dialog
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: jasper (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 08:31 EST by Joel Uckelman
Modified: 2009-02-06 00:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 00:21:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a ZIP archive containing the offending ICNS file (152.44 KB, application/zip)
2009-01-23 08:31 EST, Joel Uckelman
no flags Details

  None (edit)
Description Joel Uckelman 2009-01-23 08:31:01 EST
Created attachment 329832 [details]
a ZIP archive containing the offending ICNS file

Description of problem:

I was attempting to select an ICNS file as an attachment for Bug 481284, but every time I clicked on it in Firefox's file chooser dialog, Firefox immediately crashed. I suspect that this has something to do with attempting to create a preview to display in the file chooser dialog, and that something is failing catastrophically during that process. I've attached the ICNS file which makes this happen for me---but wrapped in a ZIP archive, since this bug prevents me from attaching the ICNS file itself.

As a side note, it made me chuckle to discover a bug whilst I was attempting to report another bug.

Version-Release number of selected component (if applicable):

firefox-3.0.5-1.fc10.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Go to a bug at bugzilla.redhat.com and attempt to add an attachment.
2. Choose the ICNS file attached to this bug in your file chooser dialog.
  
Actual results:

Firefox crashes.

Expected results:

The file should be selected. Firefox should not crash.
Comment 1 Matthias Clasen 2009-01-24 20:06:05 EST
That .icns file triggers an assertion in libjasper:

 jpc_dec.c:1072: jpc_dec_tiledecode: Assertion `dec->numcomps == 3' failed.
Comment 2 Joel Uckelman 2009-01-25 10:07:05 EST
Aha! That's very interesting.(In reply to comment #1)
> That .icns file triggers an assertion in libjasper:
> 
>  jpc_dec.c:1072: jpc_dec_tiledecode: Assertion `dec->numcomps == 3' failed.

That's very interesting. This is precisely the same exception I was reporting in libicns (Bug 481284) when I found this bug. I didn't realize that this exception was coming from libjasper.
Comment 3 Rex Dieter 2009-01-25 11:34:31 EST
Try out:
https://admin.fedoraproject.org/updates/jasper-1.900.1-9.fc10
Comment 4 Joel Uckelman 2009-01-25 11:47:45 EST
(In reply to comment #3)
> Try out:
> https://admin.fedoraproject.org/updates/jasper-1.900.1-9.fc10

I can confirm that Firefox no longer crashes when selecting the INCS file, with this build of jasper. (There's still no preview in the file chooser, though.)
Comment 5 Fedora Update System 2009-01-26 20:49:51 EST
jasper-1.900.1-9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jasper'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0986
Comment 6 Fedora Update System 2009-02-06 00:19:46 EST
jasper-1.900.1-9.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-02-06 00:21:24 EST
jasper-1.900.1-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.