Bug 481297 - fedora 10 cannot mount dmraid partition from other linux
fedora 10 cannot mount dmraid partition from other linux
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Milan Broz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 09:01 EST by Winfrid Tschiedel
Modified: 2013-02-28 23:07 EST (History)
9 users (show)

See Also:
Fixed In Version: 0.4.8-8.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 16:39:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested output from fedora10 (2.45 KB, application/octet-stream)
2009-03-20 04:57 EDT, Winfrid Tschiedel
no flags Details
Referenceoutput for openSUSE 11.1 (2.16 KB, application/octet-stream)
2009-03-20 05:31 EDT, Winfrid Tschiedel
no flags Details

  None (edit)
Description Winfrid Tschiedel 2009-01-23 09:01:38 EST
Description of problem:




Version-Release number of selected component (if applicable):
util-linux-ng-2.14.1-3.1.fc10.x86_64
I have RAID0 disk (dmraid) with several linux distributions,
fedora 10 cannot mount partition 5 ( openSUSE 10.3 ) and
partition 6 ( openSUSE 11.0 ), 
there is no problem to mount partition 2 (fedora 8) or 
partition 8 ( openSUSE 11.1 )
the other strange thing is that df -k reports the root-partition on 
/dev/dm-7 instead of /dev/mapper/pdc_cjgdhdfafhp#

[root@rx220b ~]# rpm -qa | grep util-linux-ng
util-linux-ng-2.14.1-3.1.fc10.x86_64
[root@rx220b ~]# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/dm-7             12389324   9726808   2033172  83% /
tmpfs                  1805240         0   1805240   0% /dev/shm
[root@rx220b ~]# !mo
mount /dev/mapper/pdc_cjgdhdfafhp2 /mnt1
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp5 /mnt2
mount: you must specify the filesystem type
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp6 /mnt2
mount: you must specify the filesystem type
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp8 /mnt2
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp1 /boot-loader

[root@rx220b ~]# df -kT
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/dm-7     ext3    12389324   9728652   2031328  83% /
tmpfs        tmpfs     1805240         0   1805240   0% /dev/shm
/dev/mapper/pdc_cjgdhdfafhp2
              ext3    12192636   5009180   6554112  44% /mnt1
/dev/mapper/pdc_cjgdhdfafhp8
              ext3    16302796   7976724   7497924  52% /mnt2
/dev/mapper/pdc_cjgdhdfafhp1
              ext3      101086     25935     69932  28% /boot-loader


How reproducible: always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Please compare with fedora 8 on the same system 

[root@rx220b ~]# uname -a
Linux rx220b 2.6.26.8-57.fc8 #1 SMP Thu Dec 18 18:59:49 EST 2008 x86_64 x86_64 x
86_64 GNU/Linux
[root@rx220b ~]# df -kT
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/mapper/pdc_cjgdhdfafhp2
              ext3    12192636   5009392   6553900  44% /
tmpfs        tmpfs     1806072         0   1806072   0% /dev/shm
[root@rx220b ~]# !mou
mount /dev/mapper/pdc_cjgdhdfafhp1 /boot-loader/
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp5 /mnt1
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp6 /mnt2
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp7 /mnt3
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp8 /mnt4
[root@rx220b ~]# df -kT
Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/mapper/pdc_cjgdhdfafhp2
              ext3    12192636   5009460   6553832  44% /
tmpfs        tmpfs     1806072         0   1806072   0% /dev/shm
/dev/mapper/pdc_cjgdhdfafhp1
              ext3      101086     25934     69933  28% /boot-loader
/dev/mapper/pdc_cjgdhdfafhp5
              ext3    12389324  10388528   1371452  89% /mnt1
/dev/mapper/pdc_cjgdhdfafhp6
              ext3    19125300  11336120   6817652  63% /mnt2
/dev/mapper/pdc_cjgdhdfafhp7
              ext3    12389324   9728508   2031472  83% /mnt3
/dev/mapper/pdc_cjgdhdfafhp8
              ext3    16302796   7976724   7497924  52% /mnt4
Comment 1 Karel Zak 2009-03-19 10:18:12 EDT
Did you found anything strange in dmesg output or in system logs?

Please, try:

 dmsetup ls
 blkid /dev/mapper/pdc_cjgdhdfafhp5
 /lib/udev/vol_id /dev/mapper/pdc_cjgdhdfafhp5
 mount -v -v -v /dev/mapper/pdc_cjgdhdfafhp5 /tmp
Comment 2 Winfrid Tschiedel 2009-03-20 04:57:41 EDT
Created attachment 335988 [details]
requested output from fedora10
Comment 3 Winfrid Tschiedel 2009-03-20 05:31:32 EDT
Created attachment 336006 [details]
Referenceoutput for openSUSE 11.1

Fedora 10 cannot mount partition 5 ( openSUSE 10.3 ) and
partition 6 ( openSUSE 11.0 ) - there is no problem with other partitions
( 2 = fedora 8; 8 = openSUSE 11.1 )

this output shows, that openSUSE 11.1 has no problem to mount any partition on
the disk.
Comment 4 Milan Broz 2009-03-20 07:50:56 EDT
I think this is the same problem with extended partition handling we fixed for rawhide in bug 475283.

Just to verify - please can you paste output from "dmsetup ls; dmsetup table"
from both working (OpenSuse) and failed (Fedora) system?

I am not sure if it is possible to pick up and test to upgrade kpartx package from rawhide on this system, but if possible, it should be fixed in kpartx-0.4.8-9.fc11.
Comment 5 Winfrid Tschiedel 2009-03-20 09:08:06 EDT
requested output from openSUSE 11.1 :

Linux rx220b 2.6.27.19-3.2-default #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux
rx220b:~ # dmsetup ls; dmsetup table
pdc_cjgdhdfafh_part2    (253, 2)
pdc_cjgdhdfafh  (253, 0)
pdc_cjgdhdfafh_part1    (253, 1)
pdc_cjgdhdfafh_part8    (253, 8)
pdc_cjgdhdfafh_part7    (253, 7)
pdc_cjgdhdfafh_part6    (253, 6)
pdc_cjgdhdfafh_part5    (253, 5)
pdc_cjgdhdfafh_part4    (253, 4)
pdc_cjgdhdfafh_part3    (253, 3)
pdc_cjgdhdfafh_part2: 0 25173855 linear 253:0 208845
pdc_cjgdhdfafh: 0 156118912 linear 8:0 0
pdc_cjgdhdfafh_part1: 0 208782 linear 253:0 63
pdc_cjgdhdfafh_part8: 0 33125967 linear 253:4 89209008
pdc_cjgdhdfafh_part7: 0 25173792 linear 253:4 64035153
pdc_cjgdhdfafh_part6: 0 38861172 linear 253:4 25173918
pdc_cjgdhdfafh_part5: 0 25173792 linear 253:4 63
pdc_cjgdhdfafh_part4: 0 122334975 linear 253:0 33768630
pdc_cjgdhdfafh_part3: 0 8385930 linear 253:0 25382700

requested output from fedora 10 :

[root@rx220b ~]# rpm -qa | grep kpartx
kpartx-0.4.8-7.fc10.x86_64
[root@rx220b ~]# uname -a
Linux rx220b 2.6.27.19-170.2.35.fc10.x86_64 #1 SMP Mon Feb 23 13:00:23 EST 2009
x86_64 x86_64 x86_64 GNU/Linux
[root@rx220b ~]# dmsetup ls; dmsetup table
pdc_cjgdhdfafhp2        (253, 2)
pdc_cjgdhdfafh  (253, 0)
pdc_cjgdhdfafhp1        (253, 1)
pdc_cjgdhdfafhp8        (253, 8)
pdc_cjgdhdfafhp7        (253, 7)
pdc_cjgdhdfafhp6        (253, 6)
pdc_cjgdhdfafhp5        (253, 5)
pdc_cjgdhdfafhp4        (253, 4)
pdc_cjgdhdfafhp3        (253, 3)
pdc_cjgdhdfafhp2: 0 25173855 linear 253:0 208845
pdc_cjgdhdfafh: 0 156118912 linear 8:0 0
pdc_cjgdhdfafhp1: 0 208782 linear 253:0 63
pdc_cjgdhdfafhp8: 0 33125967 linear 253:0 122977638
pdc_cjgdhdfafhp7: 0 25173792 linear 253:0 97803783
pdc_cjgdhdfafhp6: 0 38861172 linear 253:4 58942548
pdc_cjgdhdfafhp5: 0 25173792 linear 253:4 33768693
pdc_cjgdhdfafhp4: 0 122334975 linear 253:0 33768630
pdc_cjgdhdfafhp3: 0 8385930 linear 253:0 25382700
[root@rx220b ~]#

After update of kpartx + device-mapper-multipath + reboot !

[root@rx220b ~]# rpm -qa | grep kpartx
kpartx-0.4.8-9.fc11.x86_64
[root@rx220b ~]# rpm -qa | grep device
device-mapper-multipath-0.4.8-9.fc11.x86_64
device-mapper-libs-1.02.27-7.fc10.x86_64
device-mapper-devel-1.02.27-7.fc10.x86_64
device-mapper-1.02.27-7.fc10.x86_64
[root@rx220b ~]# mount /dev/mapper/pdc_cjgdhdfafhp5 /mnt1

The problems seems to be fixed.

Thank you.

TGiF,

Winfrid
Comment 6 Milan Broz 2009-03-20 12:37:47 EDT
(In reply to comment #5)
> requested output from openSUSE 11.1 :
> pdc_cjgdhdfafh  (253, 0)
> pdc_cjgdhdfafh_part5    (253, 5)
> pdc_cjgdhdfafh_part4    (253, 4)

> pdc_cjgdhdfafh: 0 156118912 linear 8:0 0
> pdc_cjgdhdfafh_part5: 0 25173792 linear 253:4 63
> pdc_cjgdhdfafh_part4: 0 122334975 linear 253:0 33768630

> 
> requested output from fedora 10 :

> pdc_cjgdhdfafh  (253, 0)
> pdc_cjgdhdfafhp5        (253, 5)
> pdc_cjgdhdfafhp4        (253, 4)

> pdc_cjgdhdfafh: 0 156118912 linear 8:0 0
> pdc_cjgdhdfafhp5: 0 25173792 linear 253:4 33768693
> pdc_cjgdhdfafhp4: 0 122334975 linear 253:0 33768630

yes, there is apparently wrong offset, caused by 
missing patch for kpartx & extended partition in Fedora10.
Comment 7 Fedora Update System 2009-03-22 12:20:32 EDT
device-mapper-multipath-0.4.8-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/device-mapper-multipath-0.4.8-8.fc10
Comment 8 Fedora Update System 2009-03-23 12:00:51 EDT
device-mapper-multipath-0.4.8-8.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update device-mapper-multipath'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2978
Comment 9 Winfrid Tschiedel 2009-03-24 07:28:18 EDT
I don't think that the update will work when kpartx and device-mapper-multipath from rawhide are installed.

Winfrid
Comment 10 Fedora Update System 2009-03-31 16:39:37 EDT
device-mapper-multipath-0.4.8-8.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.