Bug 481314 - qpidc source rpm build behaves differently if ../specs exists
qpidc source rpm build behaves differently if ../specs exists
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: messaging-bugs
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 10:20 EST by Jeff Needle
Modified: 2015-11-15 19:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 11:17:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2009-01-23 10:20:53 EST
This is a spinoff of bug 481307 since there are really two different issues that need to be addressed independently.

Justin's additions to 481307 explain the issue in building qpidc srpm.  See 481307 for relevant log snippets.


"Additional info:
2. The test that qpid/cpp is using to determine whether to generate code is
possibly wrong.  It appears that if a spec file is present at all at
../specs/qpid.0-10....xml, it generates code.  This is not favorable when we
build from our dist tarball.

It would be better if the qpid/cpp makefiles instead checked to see if the code
was already generated, as it is in dist tarball's case."
Comment 1 Alan Conway 2009-02-16 09:12:40 EST
I think this is just a matter of adding the rgen.timestamp and mgen.timestamp files to EXTRA_DIST, since these are the files that make is using to determine if generated code is current.
Comment 3 Alan Conway 2010-01-11 14:41:47 EST
comment 1 is not correct. From a developers point of view you want the code re-generated if the xml spec file is newer than any of the generated files. In an installation or in the distro I don't think we can't guarantee what the relative times of those files will be.
Comment 4 Gordon Sim 2010-07-01 11:17:08 EDT
The brew build now always regenerates sources from specs so the original issue is no longer a problem. While more control over regeneration may be worth looking at in the future it is not a pressing issue.

Note You need to log in before you can comment on or make changes to this bug.